Apple Rejection - Content failed to load on an IPv6 WiFi Network

Avatar

Avatar

thadsauer

Avatar

thadsauer

thadsauer

13-09-2016

Hi,

Has anyone run into this?

App update from DPS to AEMM app rejected by Apple today:

"We discovered one or more bugs in your app when reviewed on iPad running iOS 10.0 on Wi-Fi connected to an IPv6 network.

Specifically, your app content did not load.

Next Steps: Please run your app on a device while connected to an IPv6 network (all apps must support IPv6) to identify the issue(s), then revise and resubmit your app for review."

We've had numerous issues with Apple on this one. We actually have the same app already approved by Apple under another name while we we trying to get this through review over the last four weeks. The only differences are the new app uses 2016.11 and they tested with iOS 10.

Thoughts?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

MatthewLaun

Employee

Avatar

MatthewLaun

Employee

MatthewLaun
Employee

14-09-2016

There is good evidence that this type of failure is based on issues at the locations where Apple has employees reviewing the app submissions. Resubmission of the same app with no changes regularly results in approval. For examples:

https://forums.xamarin.com/discussion/74257/app-store-rejected-wi-fi-connected-to-an-ipv6-network

I suggest you re-submit the app, or submit a ticket to the App Review Board using the link on this page:

https://developer.apple.com/support/app-review/

My guess is that the review board ticket, and sometimes the re-submission, result in the testing being performed by a different person in a different location, and that is the reason for approval with no changes.

Answers (2)

Answers (2)

Avatar

Avatar

thadsauer

Avatar

thadsauer

thadsauer

20-09-2016

Our app was finally approved after several rounds of questions. No changes required to the AEMM app. Exasperating.

Avatar

Avatar

Vinod_Tanwar

Employee

Avatar

Vinod_Tanwar

Employee

Vinod_Tanwar
Employee

14-09-2016

Hi Thad,

This does not seems to be an issue with iOS 10 however an issue with 2016.11 update. As all iOS apps needs to be complained with IPV6 from along time now.

Please contact Enterprise Support for it, you can find the contact details in AEM Mobile portal under Support section.

Vinod Tanwar