Android app installed but will not open

jasonk3692326

23-10-2015

Hi just getting into this application today have created a test application that has been signed using a keystore, it is installed on my Sony Xperia M4 but when I click on the app it begins to load up before crashing back to the previous screen. Can anyone help?

Jason

Accepted Solutions (1)

Accepted Solutions (1)

Neil_Enns_-_Ado

Employee

26-10-2015

I took a look and it’s crashing because there’s nothing in your top-level collection when the viewer asks for it. This is a known bug in the Android viewer that will be addressed in our next release.

Your screen grab doesn’t show whether your default collection is published. Try the following:

1) If the app isn’t built as a preflight app, check the box next to the default collection and click the publish button

2) If the app is built as a preflight app, click the preflight button in the top right of the content dashboard

3) Clear app data on the device for the app

4) Wait about 10 minutes, then run the app again

Neil

Answers (13)

Answers (13)

Neil_Enns_-_Ado

Employee

26-10-2015

Yes, but is it in your top-level collection? Just having an article isn’t sufficient, you have to put it into your top-level collection.

Neil

Neil_Enns_-_Ado

Employee

26-10-2015

Can you send me a link to the APK on Creative Cloud or Dropbox or something? I can try installing it and seeing if anything shows in the log.

Neil

jasonk3692326

26-10-2015

Me and a colleague have both tried this, we built two test apps independently of each other and run them on our Android phones and both encounter the same error, could it be a problem with the keystore we created as they were both created using a JDK?

Jason