Adding image urls with presets having $ in CSS file

Avatar

Avatar

Ravi_Pampana

MVP

Avatar

Ravi_Pampana

MVP

Ravi_Pampana
MVP

08-10-2020

When we add absolute image url with preset having $, the css file will not load and throw exception from OOB code (com/adobe/granite/ui/clientlibs/script/Utils.java)

 

But by escaping $ we can overcome above issue and load the css file with preset correctly.

 

.load {
      background:url("https://scene7.image.com/is/image/adobe/someimageutl?\$native\$");
}

 

 

4 Comments

Avatar

Avatar

hamidk92094312

Employee

Avatar

hamidk92094312

Employee

hamidk92094312
Employee

08-10-2020

Hi @Ravi_Pampana 

This looks like more of something that requires problem analysis to understand the root cause. I believe at this point it does not qualify for an idea or feature request. Your participation in the community is appreciated.

Status changed to: New

Avatar

Avatar

hamidk92094312

Employee

Avatar

hamidk92094312

Employee

hamidk92094312
Employee

16-12-2020

Updating the status accordingly since this seems something that requires problem analysis to understand the root cause.

Status changed to: Declined

Avatar

Avatar

Ravi_Pampana

MVP

Avatar

Ravi_Pampana

MVP

Ravi_Pampana
MVP

16-12-2020

@hamidk92094312 , I raised day care ticket after finding the root cause of the issue (E-000224031) and I was told the issue will be fixed in AEM 6.6. 

Avatar

Avatar

hamidk92094312

Employee

Avatar

hamidk92094312

Employee

hamidk92094312
Employee

16-12-2020

@Ravi_Pampana 

Thanks for sharing the update. You took the right approach as this seemed to be an issue rather than a feature request. So lets keep the IDEAS section of the community for submitting feature requests. Thanks