Unable to login to admin ui in AEM Forms 6.5 JEE

Avatar

Avatar

Bibhu_Bikash_Na

Avatar

Bibhu_Bikash_Na

Bibhu_Bikash_Na

06-04-2021

Hello All,

We have 6.5 AEM Forms JEE + Weblogic + MS SQL Server. Frequently we are unable to login to admin ui using administrator and password. After restarting the managed server, admin server and node manager it works. But it happens mostly on a daily basis. Any idea?

Accepted Solutions (0)

Answers (3)

Answers (3)

Avatar

Avatar

PulkitJain

Employee

Avatar

PulkitJain

Employee

PulkitJain
Employee

06-04-2021

@Bibhu_Bikash_Na 

Based on the log[0] shared, please check the value of "enable Test Connections On Reserve" under Admin Console -> Navigate to the Data Source's Configuration -> Connection Pool -> (Advanced) -> check "Test Connections On Reserve"

Restart the node/admin server and monitor for any further issues. 

 

[0] - ... Caused By: java.sql.SQLException: Attempt to set connection harvestable to false but the connection is already closed.

 

Avatar

Avatar

Bibhu_Bikash_Na

Avatar

Bibhu_Bikash_Na

Bibhu_Bikash_Na

06-04-2021

Hi Sameer,

 

Thanks for your quick response. It's an un-clustered server. We are getting the below error while we try to login.

 

####<Apr 5, 2021 1:54:32,790 AM EDT> <Error> <com.adobe.idp.docmanager.service.DocumentManagerServiceImpl> <rpc15030.corp.ncr.com> <DEV63> <purgeDeletionLoop> <<anonymous>> <BEA1-10430FC818DB69C13B23> <8038c75e-fa71-4021-b6fd-d077a31f0725-00000008> <1617602072790> <[severity-value: 8] [rid: 0:145] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000000> <Error in batch-delete!
java.lang.RuntimeException: java.sql.SQLException: Attempt to set connection harvestable to false but the connection is already closed.


Caused By: java.sql.SQLException: Attempt to set connection harvestable to false but the connection is already closed.

 

Thanks,

Bibhu.

Avatar

Avatar

SameerDhawan

Avatar

SameerDhawan

SameerDhawan

06-04-2021

Hi @Bibhu_Bikash_Na ,

Please confirm if this is Cluster/standalone Environment.

If this Cluster Setup,

a) Please confirm which caching mechanism we are using 

> TCP

> UDP

 

b) There should not be any time difference between the Cluster Nodes

c) Share the Error that you are getting in the logs when trying to login to /adminui

 

Regards

Sameer Dhawan