OSGi Web Console on AEM Forms 6.2 JEE (JBOSS)

Avatar

Avatar

markj50695061

Avatar

markj50695061

markj50695061

06-02-2018

I'm running AEM Forms 6.2 JEE for JBOSS with the latest Service packs and hotfixes.

Everything works properly, except that I'm unable to access the Web Console at http://localhost:8080/lc/system/console/configMgr or with other URL variations.

I can't access the rest of the OSGi related pages either.  We consistently receive a HTTP Status 403 error code - "JBWEB000123:  Access to the specified resource has been forbidden".

My question is whether the Web Console and related OSGi configuration pages are available on the JEE version to begin with, or if there's an issue with our install that needs to be investigated.  Should the web console be accessible on the JEE version?

Note, that crx de and other primary AEM related pages are accessible and working properly.

Thank You

JBWEB000065: HTTP Status 403 -


JBWEB000309: type JBWEB000067: Status report

JBWEB000068: message

JBWEB000069: description JBWEB000123: Access to the specified resource has been forbidden.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Khushwant_Singh

Avatar

Khushwant_Singh

Khushwant_Singh

07-02-2018

Hi Mark,

Credentials of JEE and OSGi side are different. Ensure that you are using OSGi credential to login to Web Console or other OSGi.

The default OSGi credentials are admin/admin.

Regards,

Khushwant Singh

Answers (5)

Answers (5)

Avatar

Avatar

sangrams4347653

Avatar

sangrams4347653

sangrams4347653

29-10-2019

Additional log

[10/30/19 13:13:28:605 JST] 00000713 LTPAServerObj E   SECJ0369E: Authentication failed when using LTPA. The exception is com.ibm.websphere.wim.exception.PasswordCheckFailedException: CWWIM4537E  No principal is found from the 'admin' principal name..

[10/30/19 13:13:28:606 JST] 00000713 FormLoginExte E   SECJ0118E: Authentication error during authentication for user admin

[10/30/19 13:13:28:607 JST] 00000713 FormLoginExte E   SECJ0118E: Authentication error during authentication for user admin

[10/30/19 13:13:28:607 JST] 00000713 webapp        E com.ibm.ws.webcontainer.webapp.WebApp logError SRVE0293E: [Servlet Error]-[java.lang.IllegalArgumentException: Location cannot be null in javax.servlet.http.HttpServletResponse.sendRedirect(location)]: java.lang.IllegalArgumentException: Location cannot be null in javax.servlet.http.HttpServletResponse.sendRedirect(location)

        at com.ibm.ws.webcontainer.webapp.WebAppDispatcherContext.sendRedirectWithStatusCode(WebAppDispatcherContext.java:547)

        at com.ibm.ws.webcontainer.webapp.WebAppDispatcherContext.sendRedirect(WebAppDispatcherContext.java:535)

        at com.ibm.ws.webcontainer.srt.SRTServletResponse.sendRedirect(SRTServletResponse.java:1368)

        at com.ibm.ws.security.web.FormLoginExtensionProcessor.formLogin(FormLoginExtensionProcessor.java:933)

        at com.ibm.ws.security.web.FormLoginExtensionProcessor.formLogin(FormLoginExtensionProcessor.java:253)

        at com.ibm.ws.security.web.FormLoginExtensionProcessor.handleRequest(FormLoginExtensionProcessor.java:231)

        at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:4040)

        at com.ibm.ws.webcontainer.webapp.WebAppImpl.handleRequest(WebAppImpl.java:2171)

        at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:304)

        at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:1028)

        at com.ibm.ws.webcontainer.WSWebContainer.handleRequest(WSWebContainer.java:1817)

        at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:294)

        at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:465)

        at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewRequest(HttpInboundLink.java:532)

        at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.processRequest(HttpInboundLink.java:318)

        at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.ready(HttpInboundLink.java:289)

        at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminators(NewConnectionInitialReadCallback.java:214)

        at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:113)

        at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:175)

        at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)

        at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)

        at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:138)

        at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:204)

        at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:775)

        at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)

        at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1892)

Avatar

Avatar

sangrams4347653

Avatar

sangrams4347653

sangrams4347653

29-10-2019

Hi All Experts,

I am new to this AEM technology, have installed AEM 6.4 able to login to /adminui but getting error as below for other admin consoles.

Good Day!!

We have installed AEM 6.4 are able to login to /adminui but rest all the admin consoles are redirecting to lc/lib URL and when trying to login using the target URL using admin/admin it throws the /c/j_security_check page not allow to login, i am struggling on this, your kind help or direction will help us.

AEM 6.4

WebSphere 9.0

DB Oracle

URL trying to access not accesible

http://localhost:8080/lc/system/console

http://localhost:8080/lc/crx/packmgr/

ttp://localhost:8080/lc/system/console/configMgr

All these above URL redirects to http://localhost:8080/lc/libs/livecycle/core/content/login.html?ap=1

Once ID password provided its shows the below page(admin/admin)

http://localhost:8080/lc/j_security_check

as below error message

Error 500: java.lang.IllegalArgumentException: Location cannot be null in javax.servlet.http.HttpServletResponse.sendRedirect(location)

AEMError.PNG

Avatar

Avatar

James_R_Green

Avatar

James_R_Green

James_R_Green

07-02-2018

Hi markj50695061​,

Do you get the login prompt if you logout first ( go to localhost:8080/lc -> select your profile icon top right -> and click sign out), clear your browsers cache and then go to http://localhost:8080/lc/system/console/configMgr

I think I have had problems where it caches the login

Avatar

Avatar

markj50695061

Avatar

markj50695061

markj50695061

07-02-2018

Understood, but I'm not getting a login at all.  When navigating to http://localhost:8080/lc/system/console/configMgr I immediately get the 403 error.

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

969

Correct Answer

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

969

Correct Answer

1.1K
kautuk_sahni
Community Manager

07-02-2018

Moving this to AEM Forms Topic!!