Missing XMLForm.exe?

Avatar

Avatar

Viraj_y1989

Avatar

Viraj_y1989

Viraj_y1989

15-10-2015

Whenever I try to submit data on AEM 6.0 forms or do some sort of processing, I see this error in the logs - Caused by: java.io.IOException: Executable does not exist: /Users/adobeuser/Documents/CQ/aem60/crx-quickstart/bedrock/svcnative/XMLFormService/bin/XMLForm.exe
    at com.adobe.service.ProcessResource.startProcess(ProcessResource.java:354)
    ... 281 common frames omitted

 

I checked the file location and it does not contain the .exe file. Am I missing something? I searched online for a solution but no luck yet. Any help is appreciated.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

SaketSidana

Employee

Avatar

SaketSidana

Employee

SaketSidana
Employee

15-10-2015

Please suggest if you have a pre-release aemfd package. If yes, we would recommend you to take the released bits available in AEM 6.0 official release. Such an issue was seen in one of the pre-release versions of the package. Also, make sure to install the OS specific package.

Answers (5)

Answers (5)

Avatar

Avatar

beginner_398712

Avatar

beginner_398712

beginner_398712

05-07-2018

thank you for the reference.

I am reviewing it now, I forgot to mention that we are running AEMForms publisher on a linux CentOS host.

Best

Nikolas

Avatar

Avatar

Mayank_Gandhi

Employee

Avatar

Mayank_Gandhi

Employee

Mayank_Gandhi
Employee

05-07-2018

Hi Nikolas,

Please refer to the below document and ensure that all the steps have been performed on the server:

Adobe Experience Manager Help | Install and configure PDF Generator

Avatar

Avatar

beginner_398712

Avatar

beginner_398712

beginner_398712

04-07-2018

Hello

We have the issue on our installation getting an error while posting the form.

Caused by: java.io.IOException: Executable does not exist: /opt/aem/crx-quickstart/bedrock/svcnative/XMLFormService/bin/XMLForm.exe

there is indeed a bedrock folder created under crx-quickstart but there is nothing under bedrock/svcnative/XMLFormService

I have followed the recommendation above and reinstalled the adobe-aemfd-linux-pkg-4.1.18.zip and restarted AEM but nothing happened.

Are there any instructions somewhere how to setup this pdf generation, some manual anything.?

Best Regards

Nikolas

Avatar

Avatar

Pulkit-Adobe

Avatar

Pulkit-Adobe

Pulkit-Adobe

15-10-2015

Re-installation of the package adobe-aemfd-{OS}-pkg must resolve this issue. Please let me know the package version and CQ version you are using. Can you see some other files at this path as well?

Avatar

Avatar

N_Santosh_Kumar

Employee

Avatar

N_Santosh_Kumar

Employee

N_Santosh_Kumar
Employee

15-10-2015

Vijay,

 

Were there any errors observed during the first installation of package? Can you upload error.log file?

 

 

--Santosh