Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Jsafe error during preview

yada_deloitte
Level 3
Level 3

Hi,

I get the following error message in AEM Forms CM interface when I hit on PREVIEW button. I activated the watermark option in the configuration and then I started getting this error message.

1223044_pastedImage_0.png

3 Replies
sharoon23
Employee
Employee

Hi,

You have to perform boot delegation to load rsa jars which are needed by assembler service to add watermark in the PDF generated on CM letter render. You can follow [1] to do the same.

[1]: Error while starting AEM Quickstart after installing AEM Forms

Regards,

Sufyan

yada_deloitte
Level 3
Level 3

Hi,

Sorry, didn't update my question. I did found the above link and changed my sling properties file with the below two lines but then, I get the following error:

sling.bootdelegation.class.com.rsa.jsafe.provider.JsafeJCE=com.rsa.*

sling.bootdelegation.class.org.bouncycastle.jce.provider.BouncyCastleProvider=org.bouncycastle.*

Error:

1223684_pastedImage_0.pngsharoon23

sharoon23
Employee
Employee

Hi,

Do you have a space anywhere in the installation path of your AEM installation? If yes, please remove it and then try, it should work.

yada_deloitte
Level 3
Level 3

Sorry, but I didn't get it. I am running the quick start jar file.

sharoon23
Employee
Employee

Hi,

I meant that the path where you have installed quickstart like C:\cq\.. , does it contain a space in any of the folder names in the path? If yes, please remove it and restart the server.

yada_deloitte
Level 3
Level 3

Gotcha. I checked the path. Everything looks correct but it didn't work. For some reason I renamed the folder and then it worked.