Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

installing AEM forms on JBOSS application cluster

Avatar

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
stephaniev16799
Level 2

07-12-2016

Every time I try to start the JBOSS master instance to deploy the EARs, I get a Java Fatal Error. How can  I install AEM forms without getting this error?

 

 

 

 

 

 


D:\jboss\bin>domain.bat -b adobeformsd3 -c domain_mssql.xml
Calling "D:\jboss\bin\domain.conf.bat"
Setting JAVA property to "C:\Program Files\Java\jdk1.8.0_112\bin\java"
===============================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: "D:\jboss"

  JAVA: "C:\Program Files\Java\jdk1.8.0_112\bin\java"

  JAVA_OPTS: " -Dadobeidp.serverName=adobeformsd3 -Dadobe.cache.cluster-locators
=172.30.208.100[2718],172.30.208.101[2718] -Dfile.encoding=utf8 -Djava.net.prefe
rIPv4Stack=true -DentityExpansionLimit=10000 -Dcom.adobe.livecycle.crx.integrati
on.url=http://localhost:8080 -XX:+HeapDumpOnOutOfMemoryError -Dorg.jboss.net.pro
tocol.file.useURI=false -Dorg.jboss.as.logging.per-deployment=false -Xms1024M -X
mx4096M -XX:MaxPermSize=1024M -XX:+UseCompressedOops -Djava.net.preferIPv4Stack=
true  -Djboss.modules.policy-permissions=true  -Djboss.modules.system.pkgs=org.j
boss.byteman -server"

===============================================================================

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024M; su
pport was removed in 8.0
15:51:20,915 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.7.Final-
redhat-1
15:51:21,156 INFO  [org.jboss.as.process.Host Controller.status] (main) JBAS0120
17: Starting process 'Host Controller'
[Host Controller] 15:51:22,103 INFO  [org.jboss.modules] (main) JBoss Modules ve
rsion 1.3.7.Final-redhat-1
[Host Controller] 15:51:22,448 INFO  [org.jboss.msc] (main) JBoss MSC version 1.
1.5.Final-redhat-1
[Host Controller] 15:51:22,579 INFO  [org.jboss.as] (MSC service thread 1-1) JBA
S015899: JBoss EAP 6.4.5.GA (AS 7.5.5.Final-redhat-3) starting
[Host Controller] 15:51:24,088 INFO  [org.jboss.as] (Controller Boot Thread) JBA
S010902: Creating http management service using network interface (management) p
ort (9990) securePort (-1)
[Host Controller] 15:51:24,116 INFO  [org.xnio] (MSC service thread 1-1) XNIO Ve
rsion 3.0.15.GA-redhat-1
[Host Controller] 15:51:24,125 INFO  [org.xnio.nio] (MSC service thread 1-1) XNI
O NIO Implementation Version 3.0.15.GA-redhat-1
[Host Controller] 15:51:24,286 INFO  [org.jboss.remoting] (MSC service thread 1-
1) JBoss Remoting version 3.3.6.Final-redhat-1
[Host Controller] 15:51:24,586 INFO  [org.jboss.as.remoting] (MSC service thread
 1-2) JBAS017100: Listening on 172.30.208.100:9999
[Host Controller] 15:51:26,135 ERROR [org.jboss.as.controller.management-operati
on] (Controller Boot Thread) JBAS014612: Operation ("add") failed - address: ([(
"deployment" => "adobe-livecycle-native-jboss-x86_win32.ear")]) - failure descri
ption: "JBAS010876: No deployment content with hash d7eb949e5cf6309ec842fdb0a887
301a951f06ed is available in the deployment content repository for deployment 'a
dobe-livecycle-native-jboss-x86_win32.ear'. This is a fatal boot error. To corre
ct the problem, either restart with the --admin-only switch set and use the CLI
to install the missing content or remove it from the configuration, or remove th
e deployment from the xml configuraiton file and restart."
[Host Controller] 15:51:26,138 FATAL [org.jboss.as.host.controller] (Controller
Boot Thread) JBAS010933: Host Controller boot has failed in an unrecoverable man
ner; exiting. See previous messages for details.
[Host Controller] 15:51:26,194 INFO  [org.jboss.as] (MSC service thread 1-4) JBA
S015950: JBoss EAP 6.4.5.GA (AS 7.5.5.Final-redhat-3) stopped in 35ms
[Host Controller] Java HotSpot(TM) 64-Bit Server VM warning: ignoring option Max
PermSize=1024M; support was removed in 8.0
15:51:26,630 INFO  [org.jboss.as.process.Host Controller.status] (reaper for Hos
t Controller) JBAS012010: Process 'Host Controller' finished with an exit status
 of 99
15:51:26,636 INFO  [org.jboss.as.process] (Thread-8) JBAS012016: Shutting down p
rocess controller
15:51:26,640 INFO  [org.jboss.as.process] (Thread-8) JBAS012015: All processes f
inished; exiting
Press any key to continue . . .

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 10
Mayank_Gandhi
Level 10

Likes

278 likes

Total Posts

1,101 posts

Correct Reply

181 solutions
Top badges earned
Validate 1
Contributor 2
Ignite 5
Ignite 3
Ignite 10
View profile

Avatar
Validate 1
Level 10
Mayank_Gandhi
Level 10

Likes

278 likes

Total Posts

1,101 posts

Correct Reply

181 solutions
Top badges earned
Validate 1
Contributor 2
Ignite 5
Ignite 3
Ignite 10
View profile
Mayank_Gandhi
Level 10

16-12-2016

My suggestion to point java to the JDK shipped with the installer and check for prepare install guide[0] if all step have been followed(particularly the UAC) .

[0]https://helpx.adobe.com/pdf/aem-forms/6-2/prepare-install-cluster.pdf

Answers (8)

Answers (8)

Avatar

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
stephaniev16799
Level 2

16-12-2016

I tried what was suggested (to manually remove the deployment tags from the domain_mssql.xml) then started the jboss and it worked fine. Then went to re-deploy the EARs and got this error. Repeated and same thing happened.

 

 

[Server:adobeformsd3] 09:58:14,396 INFO  [com.adobe.monitor.stats.SystemStatisti
c] (ServerService Thread Pool -- 228) Health Monitor Thread started
[Server:adobeformsd3] 09:58:15,156 INFO  [org.jboss.web] (ServerService Thread P
ool -- 67) JBAS018210: Register web context: /datamanagerservice
[Server:adobeformsd3] #
[Server:adobeformsd3] # A fatal error has been detected by the Java Runtime Envi
ronment:
[Server:adobeformsd3] #
[Server:adobeformsd3] #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000
069eaeb63, pid=1880, tid=0x0000000000000cf8
[Server:adobeformsd3] #
[Server:adobeformsd3] # JRE version: Java(TM) SE Runtime Environment (8.0_112-b1
5) (build 1.8.0_112-b15)
[Server:adobeformsd3] # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.112-b15 m
ixed mode windows-amd64 compressed oops)

 

 

 

Does it matter what order the EARs are deployed in?

Avatar

Avatar
Validate 1
Level 10
Mayank_Gandhi
Level 10

Likes

278 likes

Total Posts

1,101 posts

Correct Reply

181 solutions
Top badges earned
Validate 1
Contributor 2
Ignite 5
Ignite 3
Ignite 10
View profile

Avatar
Validate 1
Level 10
Mayank_Gandhi
Level 10

Likes

278 likes

Total Posts

1,101 posts

Correct Reply

181 solutions
Top badges earned
Validate 1
Contributor 2
Ignite 5
Ignite 3
Ignite 10
View profile
Mayank_Gandhi
Level 10

15-12-2016

Please have look at the below blog in context to error you are getting , if somehow EAR have already been deployed you might want to delete it and then retry .Also in start script bind it with IP address for ex ( (For Windows) /domain.bat -b 0.0.0.0 -c <Config_File>)

https://developer.jboss.org/thread/230229?_sscc=t

Avatar

Avatar
Boost 50
Employee
WASIL
Employee

Likes

50 likes

Total Posts

386 posts

Correct Reply

51 solutions
Top badges earned
Boost 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Boost 50
Employee
WASIL
Employee

Likes

50 likes

Total Posts

386 posts

Correct Reply

51 solutions
Top badges earned
Boost 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
WASIL
Employee

15-12-2016

Try to make changes as mentioned on [1] in domain_mssql.xml 

[1] https://muhammadkhojaye.blogspot.in/2014/01/jboss-deployment-war-error-on-startup.html  

Avatar

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
stephaniev16799
Level 2

15-12-2016

I am using the pre configured jboss

Avatar

Avatar
Validate 1
Level 10
Mayank_Gandhi
Level 10

Likes

278 likes

Total Posts

1,101 posts

Correct Reply

181 solutions
Top badges earned
Validate 1
Contributor 2
Ignite 5
Ignite 3
Ignite 10
View profile

Avatar
Validate 1
Level 10
Mayank_Gandhi
Level 10

Likes

278 likes

Total Posts

1,101 posts

Correct Reply

181 solutions
Top badges earned
Validate 1
Contributor 2
Ignite 5
Ignite 3
Ignite 10
View profile
Mayank_Gandhi
Level 10

15-12-2016

Hi Steph,

Are you using the pre-configured JBoss shipped with Aem forms ??If not ,please use the same only

Regards,

Mayank

Avatar

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
stephaniev16799
Level 2

15-12-2016

Can I use the turnkey install to create a cluster?

Avatar

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Give Back
Level 2
stephaniev16799
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
stephaniev16799
Level 2

15-12-2016

I have been looking at these instructions and keep getting this same error every time.

 

 I am attempting to install AEM forms in a JBOSS cluster.

Avatar

Avatar
Boost 5
Employee
neerava
Employee

Likes

7 likes

Total Posts

33 posts

Correct Reply

14 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 5
Affirm 3
View profile

Avatar
Boost 5
Employee
neerava
Employee

Likes

7 likes

Total Posts

33 posts

Correct Reply

14 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 5
Affirm 3
View profile
neerava
Employee

15-12-2016

Please have a look at Install instructions for JBoss at:

To install on standalone instance:

http://help.adobe.com/en_US/AEMForms/InstallTurnkey/aemforms_install_turnkey.pdf

To install on cluster:

https://helpx.adobe.com/pdf/aem-forms/6-2/install-cluster-jboss.pdf