How to use GuideSubmitServlet?

Avatar

Avatar

urs_h_

Avatar

urs_h_

urs_h_

03-02-2016

Hi 

I want to use com.adobe.aemds.guide.servlet.GuideSubmitServlet to pass custom parameters from a custom submit action to the redirect page.

http://localhost:4502/system/console/depfinder reports that the package 'com.adobe.aemds.guide.servlet' is available using maven dependeny:

<dependency> <groupId>com.adobe.aemds.guide</groupId> <artifactId>aemds-guide-core</artifactId> <version>2.2.4</version> <scope>provided</scope> </dependency>

But this package is not available in repository https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/. By the way I haven't found any javadoc of GuideSubmitServlet. Is this class not intended to be used in custom code?

Thank you,

Urs

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

urs_h_

Avatar

urs_h_

urs_h_

09-02-2016

Hi Mandeep

I was finally able to solve the problem see:

http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/aem-forms.topic.forum__...

Thank you,

Urs

Answers (5)

Answers (5)

Avatar

Avatar

urs_h_

Avatar

urs_h_

urs_h_

03-02-2016

sorry, I forgot to answer your second question: I'm using AEM Forms 6.1 with Hotfix 'AEM-FORMS-6.1-WIN-Hotfix-6717-2.2.4' installed.

Avatar

Avatar

mandeepg6805152

Employee

Avatar

mandeepg6805152

Employee

mandeepg6805152
Employee

03-02-2016

<version>6.1.1</version> ? I am sure that's not a valid version at all.

Can you let me know what release version of AEM forms are you on?

Avatar

Avatar

urs_h_

Avatar

urs_h_

urs_h_

03-02-2016

Hi Mandeep

thank you for your help.

With the dependency you proposed my pom looks like:

<dependency> <groupId>com.adobe.aemfd</groupId> <artifactId>aemfd-client-sdk</artifactId> <version>6.1.1</version> <scope>provided</scope> </dependency>

But maven build fails with following error message:

... (compile), com.adobe.aemfd:aemfd-client-sdk:jar:6.1.1 (provided)]: Failed to read artifact descriptor for com.adobe.aemfd:aemfd-client-sdk:jar:6.1.1: Could not find artifact com.adobe.aemds:adobe-aemds-pkg-parent:pom:2.4.6 in nexus-releases 

Regards,

Urs

Avatar

Avatar

mandeepg6805152

Employee

Avatar

mandeepg6805152

Employee

mandeepg6805152
Employee

03-02-2016

You should be using 

<groupId>com.adobe.aemfd</groupId> <artifactId>aemfd-client-sdk</artifactId>

as a dependency instead.