DDX Failing While applying Watermark for a Tagged PDF

Avatar

Avatar

sureshg5

Avatar

sureshg5

sureshg5

13-08-2020

We are using DDX to watermark the text on the first page of input PDF. 

 

Issue : If the input PDF is tagged then DDX is failing while extracting the 1st page to apply the watermark.

sureshg5_1-1597381755651.png

if it is not a tagged PDF ,we are getting the expected result.

 

Please find the DDX command below.

DDX Command:

<DDX xmlns=""/>

<PDF result ="watermarked" return ="false" save="Full">

   <PDF source = "doc1" pages ="1">

        <PageRotation roatate90 = "90"/>

   </PDF>

      <Watermark

       alternation ="None"

       fitToPage ="false"

        horizontalAnchor = "Left" horizontalOffset ="-10mm"

        verticalAnchor = "Bottom" verticalOffset = "-10mm"

        opacity = "100%"

        scale = "100%"

        showOnScreen = "true"

        showWhenPrinting ="true"

        replaceExisting ="true">

        <StyledText color="black" font-family="Arial" font-size="16pt">

            <p margin-bottom="0pt" margin-top="0pt" margin-right="0pt">-Elextronically Approved by </p>

       </StyledText>

      </Watermark>

    </PDF>

     <PDF result ="Result" save="Full">

         <PDF source ="watermarked" pages="1">

                <PageRotation rotate90="0"/>

          </PDF>

         <PDF source="doc1" pages = "2-last" required= "false"/>

       </PDF>

        </DDX>

     

 

Doubts:

  1. Is it possible to apply watermark on 1st page alone without extracting   ? if yes , how?
  2. Is there any ways to delete the tags from PDF using DDX or Adobe Workbench?
  3. Apart from this , are they any solution can we apply to fix this issue?

 

And I am new to this , so Please help me out to fix this issue.

Thanks in Advance.

Suresh G

 

 

 

DDX Tagged PDF watermark workbench

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Kosta_Prokopiu1

Employee

Avatar

Kosta_Prokopiu1

Employee

Kosta_Prokopiu1
Employee

26-08-2020

Hi,
you have a typo in your DDX roatate90="90" must be rotate90="90"

I am not sure that the tagging is the problem, the DDX works with tagged and untagged documents here.

regarding 1.: The watermark must be associated to a set of surfaces in a PDF tag which is done in the way you have done it. I don't think you can do it more simple than that.
regarding 2.: Not that I know of, but I also don't think that tagging is your problem. What kind of PDF are you using? Do you have dynamic XFA?

There may be other reasons why the Watermark cannot be placed. Protection, dynamic XFA PDF (which gets rendered with XFA plugin).
Which version of AEM Forms are you using?

Answers (0)