Checkbox doesn't change value using xpd template binding on adaptative form

Avatar

Avatar

adolfos35734979

Avatar

adolfos35734979

adolfos35734979

27-10-2020

Hi,

 

I am working on Aem forms designer and AEM 6.5, I have created a xdp template on Designer and using it with an adaptive template when I drag a check box from the Data source tab but the value of the checkbox never changes always is 1. I have defined two-state values on Designer.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Kosta_Prokopiu1

Employee

Avatar

Kosta_Prokopiu1

Employee

Kosta_Prokopiu1
Employee

28-10-2020

I did a quick test and I can reproduce your issue - btw it not only keeps the value=1 but also after one toggle the checkbox will not change any more. Instead of value we get new properties in the DIV section (checked=true) but the visuals do not show the state. This seems to be a bug and you may want to open a case with Adobe support to see if there is a fix.I run on AEM Forms 6.5.5 - maybe 6.5.6 has that resolved?

The only workaround was to do away with the binding as it then works again - but that may produce issues when you submit the form. Has anyone here seen this before and got a working solution?

Kosta_Prokopiu1_0-1603874463436.png

 

Answers (2)

Answers (2)

Avatar

Avatar

Mayank_Gandhi

Employee

Avatar

Mayank_Gandhi

Employee

Mayank_Gandhi
Employee

05-11-2020

@adolfos35734979  I similar fix will be delivered in the upcoming release of 6.5.7 and 6.4.8.

Avatar

Avatar

adolfos35734979

Avatar

adolfos35734979

adolfos35734979

27-10-2020

adolfos35734979_0-1603878576274.png

adolfos35734979_0-1603878898566.png

 

adolfos35734979_2-1603878666977.pngadolfos35734979_3-1603878753807.png