Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

AEM formsservice throws NullPointer Exception on start of JBOSS server

Avatar

Avatar
Level 1
manugupta
Level 1

Likes

0 likes

Total Posts

5 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
manugupta
Level 1

Likes

0 likes

Total Posts

5 posts

Correct Reply

0 solutions
View profile
manugupta
Level 1

05-02-2021

 

AEM Forms JEE on Windows 2012 R2
Version 6.2.0, GM
Service Pack Version: N/A
Patch Version: N/A

 

Hi folks

We have recently observed on our QA/production instance whenever we restart our service then our formsservice component throws a nullpointer exception during start up. After start, when we try to hit workflow to generate fillable PDF which is calling FormsService component's renderPDFForm method it fails to load and throw error in generating pdf.

Though other component services work fine like OutputServices or Assembler service.

 

Even after multiple restart of JBOSS service it doesnt help and we have to do full VM reboot to bring the services to normal operations.

 

Any idea what needs to be done or this is a known issue?

 

Thanks

Manu

 

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Affirm 100
Employee
Kosta_Prokopiu1
Employee

Likes

165 likes

Total Posts

369 posts

Correct Reply

107 solutions
Top badges earned
Affirm 100
Validate 1
Establish
Give Back 5
Give Back 3
View profile

Avatar
Affirm 100
Employee
Kosta_Prokopiu1
Employee

Likes

165 likes

Total Posts

369 posts

Correct Reply

107 solutions
Top badges earned
Affirm 100
Validate 1
Establish
Give Back 5
Give Back 3
View profile
Kosta_Prokopiu1
Employee

05-02-2021

Hi,

 

you are running an unsupported version of Forms - contacting Support is probably not an option for you - but would be the right thing to do in such a case.

 

Usually, when things that worked suddenly stop working something must have changed. As I doubt that you updated AEM Forms by the sound of it, it must come from the OS or system components. For example a Windows Update or policy changes or permission changes, runtime stuff such as .NET etc.

At least you can get it back when you reboot the server, but the more I suspect that the reason lies with the system and not AEM Forms.

Answers (1)

Answers (1)

Avatar

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

327 likes

Total Posts

1,150 posts

Correct Reply

185 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

327 likes

Total Posts

1,150 posts

Correct Reply

185 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile
Mayank_Gandhi
Level 10

06-02-2021

@manugupta  Without log snippet, difficult to suggest anything. Paste some more details here and as @Kosta_Prokopiu1  6.2 is  end of core support so you should upgrade to 6.4 or later.