AEM Forms 6.3, Service Pack 2, CF2 installation on Linux errors

briankasingli-4 25-07-2018

Hello,

After installing AEM Forms 6.3.2.2, our AEM cannot be restarted and is stuck on startup. We ensure that the Boot delegate RSA and BouncyCastle libraries are included in the sling.properties file after installing AEM Forms and dependencies packages. Also before the restart of AEM after the the Forms Package installation, there were many bundles such as the AEMFD Signatures Bundle cannot be started.

Environment:

  1. AEM 6.3 Service Pack 2, CF 2
  2. AEM 6.3 Forms Service Pack 2, CF2 (4.1.74) LINUX https://www.adobeaemcloud.com/content/marketplace/marketplaceProxy.html?packagePath=/content/compani...
  3. Linux

Timeline of how Packages installed (in order, and watch error.logs closely before starting AEM):

  1. AEM 6.3 Service Pack 2
  2. [Wait] restart after error.log's indicate that nothing else is being installed; restart AEM
  3. AEM 6.3 Service Pack 2 CF 2
  4. [Wait] restart after error.log's indicate that nothing else is being installed; restart AEM
  5. AEM Forms 6.3.2.2 (Forms Service Pack 2 CF 2) LINUX
  6. [Wait] restart after error.log's indicate that nothing else is being installed; Felix Console is checked to see if all the form bundles are active, some bundles cannot be started (indicated in the logs below); ignore bundles that cannot be activated, and restart AEM
  7. Include Boot delegate RSA and BouncyCastle libraries in sling.properties file - Installing and configuring AEM 6.3 forms
  8. restart AEM
  9. GET ERRORS, and AEM gets stuck.

ERROR LOGS:

5.07.2018 13:43:04.050 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [14918, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED

25.07.2018 13:43:17.733 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [14919, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED

25.07.2018 13:44:51.384 *ERROR* [qtp970132123-157] org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve resource com.adobe.aemfd.adobe-aemfd-assembler [com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)] because it is exposed to package 'com.adobe.xfa' from resources xfa4j [xfa4j [612](R 612.0)] and xtg [xtg [513](R 513.0)] via two dependency chains.

Chain 1:

  com.adobe.aemfd.adobe-aemfd-assembler [com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)]

    import: (&(osgi.wiring.package=com.adobe.xfa)(version>=3.6.0)(!(version>=4.0.0)))

     |

    export: osgi.wiring.package: com.adobe.xfa

  xfa4j [xfa4j [612](R 612.0)]

Chain 2:

  com.adobe.aemfd.adobe-aemfd-assembler [com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)]

    import: (&(osgi.wiring.package=com.adobe.fd.signatures.client.types)(version>=3.6.0)(!(version>=4.0.0)))

     |

    export: osgi.wiring.package=com.adobe.fd.signatures.client.types; uses:=com.adobe.fd.signatures.pdf.inputs

  adobe-aemfd-signatures [adobe-aemfd-signatures [584](R 584.0)]

    import: (&(osgi.wiring.package=com.adobe.fd.signatures.pdf.inputs)(version>=3.6.0)(!(version>=4.0.0)))

     |

    export: osgi.wiring.package=com.adobe.fd.signatures.pdf.inputs; uses:=com.adobe.internal.pdftoolkit.services.javascript

  adobe-aemfd-signatures [adobe-aemfd-signatures [584](R 584.0)]

    import: (osgi.wiring.package=com.adobe.internal.pdftoolkit.services.javascript)

     |

    export: osgi.wiring.package=com.adobe.internal.pdftoolkit.services.javascript; uses:=com.adobe.xfa

  PDFServices_security [PDFServices_security [510](R 510.2)]

    import: (osgi.wiring.package=com.adobe.xfa)

     |

    export: osgi.wiring.package: com.adobe.xfa

  xtg [xtg [513](R 513.0)] Unresolved requirements: [[com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.fd.signatures.client.types)(version>=3.6.0)(!(version>=4.0.0)))])

org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve resource com.adobe.aemfd.adobe-aemfd-assembler [com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)] because it is exposed to package 'com.adobe.xfa' from resources xfa4j [xfa4j [612](R 612.0)] and xtg [xtg [513](R 513.0)] via two dependency chains.

Chain 1:

  com.adobe.aemfd.adobe-aemfd-assembler [com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)]

    import: (&(osgi.wiring.package=com.adobe.xfa)(version>=3.6.0)(!(version>=4.0.0)))

     |

    export: osgi.wiring.package: com.adobe.xfa

  xfa4j [xfa4j [612](R 612.0)]

Chain 2:

  com.adobe.aemfd.adobe-aemfd-assembler [com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)]

    import: (&(osgi.wiring.package=com.adobe.fd.signatures.client.types)(version>=3.6.0)(!(version>=4.0.0)))

     |

    export: osgi.wiring.package=com.adobe.fd.signatures.client.types; uses:=com.adobe.fd.signatures.pdf.inputs

  adobe-aemfd-signatures [adobe-aemfd-signatures [584](R 584.0)]

    import: (&(osgi.wiring.package=com.adobe.fd.signatures.pdf.inputs)(version>=3.6.0)(!(version>=4.0.0)))

     |

    export: osgi.wiring.package=com.adobe.fd.signatures.pdf.inputs; uses:=com.adobe.internal.pdftoolkit.services.javascript

  adobe-aemfd-signatures [adobe-aemfd-signatures [584](R 584.0)]

    import: (osgi.wiring.package=com.adobe.internal.pdftoolkit.services.javascript)

     |

    export: osgi.wiring.package=com.adobe.internal.pdftoolkit.services.javascript; uses:=com.adobe.xfa

  PDFServices_security [PDFServices_security [510](R 510.2)]

    import: (osgi.wiring.package=com.adobe.xfa)

     |

    export: osgi.wiring.package: com.adobe.xfa

  xtg [xtg [513](R 513.0)] Unresolved requirements: [[com.adobe.aemfd.adobe-aemfd-assembler [538](R 538.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.fd.signatures.client.types)(version>=3.6.0)(!(version>=4.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

at org.apache.felix.webconsole.internal.core.BundlesServlet.doPost(BundlesServlet.java:364)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:644)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)

at org.apache.felix.webconsole.internal.servlet.OsgiManager.service(OsgiManager.java:563)

at org.apache.felix.webconsole.internal.servlet.OsgiManager$3.run(OsgiManager.java:465)

at java.security.AccessController.doPrivileged(Native Method)

at org.apache.felix.webconsole.internal.servlet.OsgiManager.service(OsgiManager.java:461)

at org.apache.felix.http.base.internal.handler.ServletHandler.handle(ServletHandler.java:85)

at org.apache.felix.http.base.internal.dispatch.InvocationChain.doFilter(InvocationChain.java:79)

at com.adobe.granite.license.impl.LicenseCheckFilter.doFilter(LicenseCheckFilter.java:308)

at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:135)

at org.apache.felix.http.base.internal.dispatch.InvocationChain.doFilter(InvocationChain.java:74)

at org.apache.felix.http.sslfilter.internal.SslFilter.doFilter(SslFilter.java:96)

at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:135)

at org.apache.felix.http.base.internal.dispatch.InvocationChain.doFilter(InvocationChain.java:74)

at org.apache.sling.security.impl.ReferrerFilter.doFilter(ReferrerFilter.java:295)

at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:135)

at org.apache.felix.http.base.internal.dispatch.InvocationChain.doFilter(InvocationChain.java:74)

at org.apache.sling.i18n.impl.I18NFilter.doFilter(I18NFilter.java:131)

at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:135)

at org.apache.felix.http.base.internal.dispatch.InvocationChain.doFilter(InvocationChain.java:74)

at org.apache.felix.http.base.internal.dispatch.Dispatcher.dispatch(Dispatcher.java:127)

at org.apache.felix.http.base.internal.dispatch.DispatcherServlet.service(DispatcherServlet.java:49)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)

at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:812)

at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:587)

at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:221)

at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)

at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)

at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)

at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)

at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)

at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:215)

at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)

at org.eclipse.jetty.server.Server.handle(Server.java:499)

at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)

at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:258)

at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)

at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)

at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)

at java.lang.Thread.run(Thread.java:748)

25.07.2018 13:45:26.490 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [14920, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED

25.07.2018 13:45:26.617 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [14921, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED

25.07.2018 13:45:26.648 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [14922, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED

...

...

...

...

...

...

...

...

...

...

...

...

...

...

...

5.07.2018 13:17:43.419 *INFO* [OsgiInstallerImpl] aem-dermis-core Service [com.adobe.aem.dermis.core.webservice.WSConnector,13477, [com.adobe.aem.dermis.api.Connector]] ServiceEvent REGISTERED

25.07.2018 13:17:43.419 *INFO* [OsgiInstallerImpl] forms-foundation-wsdl-bundle Service [com.adobe.forms.foundation.wsdl.WSDLInvokerService,13476, [com.adobe.forms.foundation.wsdl.WSDLInvokerService]] ServiceEvent REGISTERED

25.07.2018 13:17:43.419 *INFO* [OsgiInstallerImpl] forms-foundation-wsdl-bundle BundleEvent STARTED

25.07.2018 13:17:43.419 *INFO* [OsgiInstallerImpl] org.apache.sling.audit.osgi.installer Started bundle forms-foundation-wsdl-bundle [579]

25.07.2018 13:17:43.420 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle com.adobe.aemfd.adobe-aemfd-pdfutility [580]. Reason: {}. Will retry.

org.osgi.framework.BundleException: Unable to resolve com.adobe.aemfd.adobe-aemfd-pdfutility [580](R 580.0): missing requirement [com.adobe.aemfd.adobe-aemfd-pdfutility [580](R 580.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemfd.docmanager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-docmanager [551](R 551.0): missing requirement [adobe-aemds-core-docmanager [551](R 551.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.bedrock.internal)(version>=1.9.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-bmc [547](R 547.0): missing requirement [adobe-aemds-core-bmc [547](R 547.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.connector.repository)(version>=1.9.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-common [550](R 550.0): missing requirement [adobe-aemds-core-common [550](R 550.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.idp)(version>=10.0.0)(!(version>=11.0.0)))]]] Unresolved requirements: [[com.adobe.aemfd.adobe-aemfd-pdfutility [580](R 580.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemfd.docmanager)(version>=1.2.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:894)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:729)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:286)

at java.lang.Thread.run(Thread.java:748)

25.07.2018 13:17:43.421 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle adobe-aemfd-docassurance [581]. Reason: {}. Will retry.

org.osgi.framework.BundleException: Unable to resolve adobe-aemfd-docassurance [581](R 581.0): missing requirement [adobe-aemfd-docassurance [581](R 581.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.fd.encryption.internal.api)(version>=3.6.0)(!(version>=4.0.0))) [caused by: Unable to resolve adobe-aemfd-encryption [582](R 582.0): missing requirement [adobe-aemfd-encryption [582](R 582.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.settings)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-common [550](R 550.0): missing requirement [adobe-aemds-core-common [550](R 550.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.idp)(version>=10.0.0)(!(version>=11.0.0)))]] Unresolved requirements: [[adobe-aemfd-docassurance [581](R 581.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.fd.encryption.internal.api)(version>=3.6.0)(!(version>=4.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:894)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:729)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:286)

at java.lang.Thread.run(Thread.java:748)

25.07.2018 13:17:43.421 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle adobe-aemfd-encryption [582]. Reason: {}. Will retry.

org.osgi.framework.BundleException: Unable to resolve adobe-aemfd-encryption [582](R 582.0): missing requirement [adobe-aemfd-encryption [582](R 582.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.settings)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-common [550](R 550.0): missing requirement [adobe-aemds-core-common [550](R 550.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.idp)(version>=10.0.0)(!(version>=11.0.0)))] Unresolved requirements: [[adobe-aemfd-encryption [582](R 582.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.settings)(version>=1.2.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:894)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:729)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:286)

at java.lang.Thread.run(Thread.java:748)

25.07.2018 13:17:43.422 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle com.adobe.aemfd.adobe-aemfd-readerextensions [583]. Reason: {}. Will retry.

org.osgi.framework.BundleException: Unable to resolve com.adobe.aemfd.adobe-aemfd-readerextensions [583](R 583.0): missing requirement [com.adobe.aemfd.adobe-aemfd-readerextensions [583](R 583.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.fd.signatures.pki.cert)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve adobe-aemfd-signatures [584](R 584.0): missing requirement [adobe-aemfd-signatures [584](R 584.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.bedrock.internal)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-bmc [547](R 547.0): missing requirement [adobe-aemds-core-bmc [547](R 547.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.settings)(version>=1.9.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-common [550](R 550.0): missing requirement [adobe-aemds-core-common [550](R 550.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.idp)(version>=10.0.0)(!(version>=11.0.0)))]]] Unresolved requirements: [[com.adobe.aemfd.adobe-aemfd-readerextensions [583](R 583.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.fd.signatures.pki.cert)(version>=3.0.0)(!(version>=4.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:894)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:729)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:286)

at java.lang.Thread.run(Thread.java:748)

25.07.2018 13:17:43.422 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle adobe-aemfd-signatures [584]. Reason: {}. Will retry.

org.osgi.framework.BundleException: Unable to resolve adobe-aemfd-signatures [584](R 584.0): missing requirement [adobe-aemfd-signatures [584](R 584.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.settings)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve adobe-aemds-core-common [550](R 550.0): missing requirement [adobe-aemds-core-common [550](R 550.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.idp)(version>=10.0.0)(!(version>=11.0.0)))] Unresolved requirements: [[adobe-aemfd-signatures [584](R 584.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemds.settings)(version>=1.2.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:894)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:729)

at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:286)

at java.lang.Thread.run(Thread.java:748)

25.07.2018 13:17:43.425 *INFO* [Adobe Granite Maintenance Scheduler Update Task] org.apache.sling.hc.core Service [13464, [javax.management.DynamicMBean]] ServiceEvent UNREGISTERING

25.07.2018 13:17:43.426 *INFO* [Adobe Granite Maintenance Scheduler Update Task] com.adobe.granite.maintenance.core Service [13463, [org.apache.sling.hc.api.HealthCheck]] ServiceEvent UNREGISTERING

25.07.2018 13:17:43.429 *INFO* [OsgiInstallerImpl] adobe-aemfd-signatures-hsm-bmc BundleEvent RESOLVED

25.07.2018 13:17:43.429 *INFO* [OsgiInstallerImpl] adobe-aemfd-signatures-hsm-bmc BundleEvent STARTING

25.07.2018 13:17:43.430 *INFO* [Adobe Granite Maintenance Scheduler Update Task] org.apache.sling.hc.core Service [13479, [javax.management.DynamicMBean]] ServiceEvent REGISTERED

25.07.2018 13:17:43.430 *INFO* [Adobe Granite Maintenance Scheduler Update Task] com.adobe.granite.maintenance.core Service [13478, [org.apache.sling.hc.api.HealthCheck]] ServiceEvent REGISTERED

25.07.2018 13:17:43.430 *INFO* [OsgiInstallerImpl] adobe-aemfd-signatures-hsm-bmc BundleEvent STARTED

..

Accepted Solutions (1)

Accepted Solutions (1)

briankasingli-4 26-07-2018

Okay, SOLVED

The issue was because we included the BouncyCastle libraries before installing the AEM Forms Package. Steps below solved the problem.

Timeline of how Packages installed (in order, and watch error.logs closely before starting AEM):

  1. AEM 6.3 Service Pack 2
  2. [Wait] restart after error.log's indicate that nothing else is being installed; restart AEM
  3. AEM 6.3 Service Pack 2 CF 2
  4. [Wait] restart after error.log's indicate that nothing else is being installed; restart AEM
  5. AEM Forms 6.3.2.2 (Forms Service Pack 2 CF 2) LINUX
  6. [Wait] restart after error.log's indicate that nothing else is being installed; restart AEM
  7. STOP AEM
  8. Include Boot delegate RSA and BouncyCastle libraries in sling.properties file - Installing and configuring AEM 6.3 forms
  9. START AEM
  10. Forms SP2 CF2 is installed!.

Answers (3)

Answers (3)

James_R_Green 25-07-2018

Hello,

How long do you leave it between restarts? I remember it taking like thirty minutes to fully settle after the aem forms install.

Having said that I have only upgraded a 6.2 forms jee instance on Linux so not sure if there are additional steps for 6.3 (osgi?) on Linux. What you note above sounds correct from memory.

I usually work my way backwards for the dependencies i.e. Start with forms addon, which requires x, download x and so on. Then install in reverse order of download.

Cheers,

Jim

P. S. Office dog