AEM Forms 6.1 update SP1 or FP2

njohnso 10-03-2016

Hello, I'm a bit confused on what I need to install to update my AEM Forms 6.1.0 environment.  In the package share, I see AEM-Forms-6.1-SP1-WIN as well as both feature packs AEM-Forms-6.1-FP1-WIN and AEM-Forms-6.1-FP2-WIN.  Are there security fixes included in FP1 and FP2?  Support indicated that I only need to install FP2 so I am a bit confused. 

 

Thank you.

Accepted Solutions (1)

Accepted Solutions (1)

_Sid_ 14-03-2016

AEM Forms 6.1

FP1 introduces these new features: https://helpx.adobe.com/content/help/en/aem-forms/6-1/whats-new-fp1.html

to upgrade to FP1 - the installation instructions applicable to your environment can be found here : https://helpx.adobe.com/aem-forms/6-1/upgrade.html

in some cases you can directly install the whole feature pack, in other cases it will be a series of small fixes that you will have to install.

 

FP2 2 simply brings in Japanese language support, and includes all other features from FP1, so you could directly choose to install FP2 as well.

Installation instructions here ::https://helpx.adobe.com/aem-forms/6-1/upgrade.html

 

The Service Pack 1 is a cumulative fix pack - although my guess is that FP2 would already include the most recent available fixes, but if you want to install SP1, it is delivered as an OSGi package, instead of an installer.

You can either navigate to the CRX console from your AEM Environment and select package share from there, or use the below link to login to package share and download the package which is applicable to your environment.

https://www.adobeaemcloud.com/content/packageshare.html

You will need to create a free Adobe ID, if you haven;t already , in order to login to package share.

Answers (1)

Answers (1)

Tuhin_Ghosh 10-03-2016

njohnso wrote...

Hello, I'm a bit confused on what I need to install to update my AEM Forms 6.1.0 environment.  In the package share, I see AEM-Forms-6.1-SP1-WIN as well as both feature packs AEM-Forms-6.1-FP1-WIN and AEM-Forms-6.1-FP2-WIN.  Are there security fixes included in FP1 and FP2?  Support indicated that I only need to install FP2 so I am a bit confused. 

 

Thank you.

 

please try this below URL. Hope it helps.

https://docs.adobe.com/docs/en/aem/6-1/deploy/upgrade.html