Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

AEM 6.2 CFP4: Submit has ns2 on tags

Avatar

Avatar
Validate 10
Level 3
joell91868939
Level 3

Likes

6 likes

Total Posts

55 posts

Correct Reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 3
joell91868939
Level 3

Likes

6 likes

Total Posts

55 posts

Correct Reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile
joell91868939
Level 3

13-06-2017

We installed AEM Forms 6.2 CFP4.

Our submit has ns2 on the xml. Any idea why? Seems to be something to do with panels.

XSD has no mention of "ns2".

"=============================="

<?xml version="1.0" encoding="UTF-8"?>

<data xmlns:xfa="http://www.xfa.org/schema/xfa-data/1.0/">

  <ns2:Metadata>

        <ApplicationId>2</ApplicationId>

        <ApplicantId>1</ApplicantId>

        <FormName>name</FormName>

        <SectionName>section</SectionName>

      </ns2:Metadata>

  <ns2:PrimaryName>

        <LastName>me</LastName>

        <NoGivenName>false</NoGivenName>

        <GivenName>me</GivenName>

  </ns2:PrimaryName>

...

</data>

"=============================="

Appears to be with JDK jdk1.8.0_92 (my machine). Doesn't occur with jdk1.8.0_74 (another machine).

But we doubt the JDK is related.

Also doesn't seem to occur on my machine when I don't do a prefill.

-Joel

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 1
Level 2
gauravahuja11
Level 2

Like

1 like

Total Posts

9 posts

Correct Reply

4 solutions
Top badges earned
Boost 1
Affirm 3
Affirm 1
View profile

Avatar
Boost 1
Level 2
gauravahuja11
Level 2

Like

1 like

Total Posts

9 posts

Correct Reply

4 solutions
Top badges earned
Boost 1
Affirm 3
Affirm 1
View profile
gauravahuja11
Level 2

11-08-2017

Hi joell91868939​,

Can you use the guideBridge API (getDataXML[0]) to verify the XML that is being posted? This XML should not have the ns2 namespace.

[0] Adaptive Forms Class: GuideBridge

Answers (2)

Answers (2)

Avatar

Avatar
Boost 5
Employee
deepak_k_
Employee

Likes

5 likes

Total Posts

84 posts

Correct Reply

32 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 5
Affirm 3
View profile

Avatar
Boost 5
Employee
deepak_k_
Employee

Likes

5 likes

Total Posts

84 posts

Correct Reply

32 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 5
Affirm 3
View profile
deepak_k_
Employee

11-08-2017

What kind of Form are you using? Is it XFA,XSD or None based Form Model?

Let me get back to you on that.

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,127 likes

Total Posts

6,121 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,127 likes

Total Posts

6,121 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

11-08-2017