Adaptive form Template not showing up

Avatar

Avatar

sobhan_sahu

Avatar

sobhan_sahu

sobhan_sahu

17-11-2017

Hi All,

I am using AEM 6.3

I copied the simpleEnrollment Template from libs folder into my application folder and I modified the title and description of the same. But it is not appearing in the template list when I am trying to create an adaptive form.

Thanks,

Sobhan

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

sobhan_sahu

Avatar

sobhan_sahu

sobhan_sahu

26-11-2017

Yes the issue got resolved.

Actually we have two sets of library templates shipped in AEM, for e.g SimpleEnrollment & SimpleEnrollment2. So basically if I have to create my template by copying the library template, then I should be copying the SimpleEnrollment2, which is a static template and changing the title of the same. we should not be copying the SimpleEnrollment template as it is a dynamic template.

Thanks,

Sobhan

Answers (6)

Answers (6)

Avatar

Avatar

arjun07180302

Avatar

arjun07180302

arjun07180302

17-11-2017

the path you mentioned is correct.  under Forms&Documents, you create folders(based on your project details) and put all your forms over there. Also, were you able to resolve the actual issue you were talking about?

Avatar

Avatar

sobhan_sahu

Avatar

sobhan_sahu

sobhan_sahu

17-11-2017

OK. Could you please post the navigations that you are following from the project.html screen.

I am following

Clicking on Adobe Experience Manager-- Forms -- Forms&Documents . here create Adaptive Forms.

Is this correct.

Thanks

Sobhan

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

17-11-2017

I just tested on AEM 6.3

AForm2.png

It showed up -

AForm1.png

Make sure you set the allowedPaths prop correctly - try using /content(/.*)?

Also - better practice to place templates under /apps/templates.

Avatar

Avatar

sobhan_sahu

Avatar

sobhan_sahu

sobhan_sahu

17-11-2017

Hi Donald,

I just copied simple enrollment template node from /libs/FD/af/templates to /apps/sobhan@gmail folder. Then just changed the JCR:title property of it as testtemplate. That's all.

I remember doing it in 6.1 working. Is there anything extra in 6.3

Thanks

Sobhan

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

17-11-2017

Post a screen shot to make sure its in the correct location.

Avatar

Avatar

sobhan_sahu

Avatar

sobhan_sahu

sobhan_sahu

17-11-2017

Is there anything I am missing here.

I am using AEM 6.3

I copied the simpleEnrollment Template from libs folder into my application folder and I modified the title and description of the same. But it is not appearing in the template list when I am trying to create an adaptive form.

Thanks,

Sobhan