Unable to choose 'Open' for Excel DAM assets in IE 11

denisew66999041

03-10-2017

Has anyone been having issues with Excel documents in the DAM opening in IE 11? If you link to Excel DAM assets they won’t open if you select the “Open” option in IE. If you choose “Save” and then open the file it’s fine. If we move the Excel file into Eloqua’s document manager, it’s fine. PDF documents are also fine. Firefox and Chrome are also fine. It doesn’t matter if the link is in an email, on a published webpage, or if someone just pastes the URL directly into the browser.

What our users are experiencing -- When you click the link for an Excel DAM asset in IE, you first get the dialog box to Open/Save/Save As. When you choose "Open", you get a blank browser window, a message displays that the file is being downloaded, and then when the message goes away you're still looking at a blank page. The file never opens.

Accepted Solutions (1)

Accepted Solutions (1)

denisew66999041

05-10-2017

It looks like Adobe has confirmed this as a defect in AEM 6.2. They fixed this of 6.3 but don't currently have plans to backport the fix to 6.2

Answers (4)

Answers (4)

jimp38732070

12-10-2017

Something you might try on 6.2.  On the dispatcher, set it to NOT cache that mime-type.  We had some issues with certain mime-types and IE11 where we needed to disable cache for save/open function to properly launch.  We have since upgraded to 6.3.

Jim P

Veena_Vikram

MVP

03-10-2017

I do see the same behaviour. What additionally I see in the access logs is a 304 request served 1317247_pastedImage_0.png

When I check another document (like an image) , I get 200 ok

1317290_pastedImage_1.png

     - I believe this could be a potential bug. May be you should create a day care ticket. I tested this in 6.3 . Which version are you trying this ?