Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Service user is not working in publish server

Avatar

Avatar
Level 1
sirishap9577191
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
sirishap9577191
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
sirishap9577191
Level 1

10-06-2021

  • I have created service user using explorer. In java code when I try to create resource resolver it is coming null. And this works in author but not in publish.  We are accessing apps in java code . So read permission is given to apps. Any kind of inputs are helpful here.

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar
Boost 5
Level 5
Ritesh_M
Level 5

Likes

74 likes

Total Posts

67 posts

Correct Reply

19 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Boost 5
Level 5
Ritesh_M
Level 5

Likes

74 likes

Total Posts

67 posts

Correct Reply

19 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
Ritesh_M
Level 5

10-06-2021

Hi @sirishap9577191 ,

 

You need to update "Apache Sling Service User Mapper Service" to add mapping for sub-service, bundle and system user configuration. Also, the system user should have proper permission. 

 

Please refer this video for more clarification 

https://www.youtube.com/watch?v=CatRHs0rt4o