Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Process implementation not found: com.day.cq.dam.s7dam.onprem.process.S7damExtractImageInfoProcess

Avatar

Avatar
Validate 1
Level 1
sultanete
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
sultanete
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
sultanete
Level 1

28-12-2017

I am working on an upgrade project from AEM 6.1 to 6.3 . Using 3.0.0 version for uber. 2.3.4 for maven-bundle-plugin , 1.9.8 for org.apache.felix.scr.annotations and 1.20.0 for maven-src-plugin.

Whenever I am uploading an image, I am getting the error as :

com.adobe.granite.workflow.WorkflowException: Process implementation not found: com.day.cq.dam.s7dam.onprem.process.S7damExtractImageInfoProcess

at com.adobe.granite.workflow.core.job.HandlerBase.executeProcess(HandlerBase.java:202)

at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:258)

at org.apache.sling.event.impl.jobs.JobConsumerManager$JobConsumerWrapper.process(JobConsumerManager.java:500)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.startJob(JobQueueImpl.java:291)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.access$100(JobQueueImpl.java:58)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl$1.run(JobQueueImpl.java:227)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

at java.lang.Thread.run(Thread.java:748)

What am I missing here.

Thanks!

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 1
Level 1
andresbott
Level 1

Like

1 like

Total Posts

1 post

Correct Reply

1 solution
Top badges earned
Boost 1
Affirm 1
View profile

Avatar
Boost 1
Level 1
andresbott
Level 1

Like

1 like

Total Posts

1 post

Correct Reply

1 solution
Top badges earned
Boost 1
Affirm 1
View profile
andresbott
Level 1

04-07-2018

Hello,

This issue seems to be related to workflow steps in "Dam Update Assets" that are no longer present in AEM 6.3

If you are modifying your workflow model in your project, please try to make your modifications based on an AEM 6.3 OOTB model.

The workflow was deprecated in 6.2 and removed in 6.3. It was a left over from 5.6.1

Answers (0)