GIF images not working with adobe dynamic media

Avatar

Avatar

karansheel

Avatar

karansheel

karansheel

19-01-2018

Hi,

We are trying to replicate a gif image to adobe dynamic server. It's get replicated successfully but when we requesting the image using dynamic media url it's giving a static image (like jpeg) instead of animated image & the format is same(gif).

Is there any parameter we need to add while requesting this image as in case of transparent image we do "fmt=png-alpha" . Is any parameter we need to pass or gif is not supported by dynamic media. i have tried it with "gif-alpha" but unfortunately it doesn't worked. We are using 6.2

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

VikramGaur

Employee

Avatar

VikramGaur

Employee

VikramGaur
Employee

18-06-2018

Hello Karan,

You need to create the property "dam:dmStatic (boolean)" in the "metadata/ folder" of the asset and set it to true.

Screen Capture attached

This is needs to be done explicitly, since GIFs are considered image content and will otherwise be delivered through /is/image.

After creating the value, change "/is/image" to "is/content"

Thanks,

Vikram Gaur

animatedgif_dynamicmedia.jpg

Answers (7)

Answers (7)

Avatar

Avatar

VikramGaur

Employee

Avatar

VikramGaur

Employee

VikramGaur
Employee

14-02-2019

Hi Nirbhay,

As I already mentioned, once you have uploaded your Animated GIF image on your AEM instance, you need to create the property "dam:dmStatic (boolean)" in the "metadata node" of the image. (just like the Screen Capture on the post)

You need to use the /crx/de (CRXDE Lite) to access the "metadata node"

Dynamic Renditions will be created with "/is/image" path, once dam:Static property is created, you may replace it with "is/content" to serve the image with Animation.

In case, you are still facing issue, please open a ticket on https://daycare.day.com/home.html or send an email to s7support@adobe.com

Avatar

Avatar

VikramGaur

Employee

Avatar

VikramGaur

Employee

VikramGaur
Employee

12-02-2019

Hi Nirbhays,

I will be setting up an AEM 6.4.2 instance with DMS7 configuration (runmode=dynamicmedia_scene7) at my end and will do some research on this.

I will get back to you on this.

Thanks,

Vikram Gaur

Avatar

Avatar

amits2757339

Avatar

amits2757339

amits2757339

12-02-2019

vikramt48656959

Hi Vikram,

We are using AEM 6.4.2 and run mode is configured to dynamicmedia_scene7.

Thanks.

Amit

Avatar

Avatar

nirbhays3027754

Avatar

nirbhays3027754

nirbhays3027754

11-02-2019

Hi Vikram,

I am using AEM 6.4.2 and run mode is configured to dynamicmedia_scene7.

Thanks.

Nirbhay Singh

Avatar

Avatar

VikramGaur

Employee

Avatar

VikramGaur

Employee

VikramGaur
Employee

08-02-2019

Hello Nirbhays,

Which AEM version are you using?

When you invoke your AEM instance, what run mode you have configured (dynamicmedia or dynamicmedia_scene7)?

Thanks,

Vikram Gaur

Avatar

Avatar

nirbhays3027754

Avatar

nirbhays3027754

nirbhays3027754

08-02-2019

VikramGaur

We are facing a similar problem:

  • Out of the box  for gif images AEM is creating .png rendition and without animation
  • With Dynamic media also the renditions are loosing animation

I am trying your solution but not sure where to find "is/image" property.

Could you please help..

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

1.0K

Correct Reply

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

1.0K

Correct Reply

1.1K
kautuk_sahni
Community Manager

31-01-2018

Moving this Question to AEM Assets Topic!!