AEM push to S7 - Handshake exception

Avatar

Avatar

kimonp31365843

Avatar

kimonp31365843

kimonp31365843

29-01-2020

Our AEM - to -Dynamic Media (S7) media upload started suddenly failing, with AEM-side work items showing the following error:

 

Caused by: java.lang.Exception: java.lang.Exception: Unable to complete Scene7 upload for asset /content/dam/myassets/my-asset.jpg: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
	at com.day.cq.dam.scene7.internal.impl.Scene7InternalUploadServiceImpl.uploadPost(Scene7InternalUploadServiceImpl.java:421)
	at com.day.cq.dam.scene7.impl.process.Scene7UploadProcess.upload(Scene7UploadProcess.java:469)
	at com.day.cq.dam.scene7.impl.process.Scene7UploadProcess.execute(Scene7UploadProcess.java:278)
	at com.day.cq.workflow.compatibility.CQWorkflowExtProcessProxy.execute(CQWorkflowExtProcessProxy.java:66)
	... 9 more
Caused by: java.lang.Exception: Unable to complete Scene7 upload for asset /content/dam/myassets/my-asset.jpg: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
	at com.day.cq.dam.scene7.internal.impl.Scene7InternalAPIClientImpl.makeMultipartFormDataRequest(Scene7InternalAPIClientImpl.java:236)
	at com.day.cq.dam.scene7.internal.impl.Scene7InternalAPIClientImpl.uploadPost(Scene7InternalAPIClientImpl.java:116)
	at com.day.cq.dam.scene7.internal.impl.Scene7InternalUploadServiceImpl.uploadPost(Scene7InternalUploadServiceImpl.java:387)
	... 12 more

 

Can someone provide some insights on this and ways to tackle/mitigate this issue? 

 

Thank you in advance

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

kimonp31365843

Avatar

kimonp31365843

kimonp31365843

29-01-2020

Apparently there was a S7-side adjustments around certificates that caused the issue. Adobe engineers fixed it, it was then just a matter now of restarting the failed workflows - problem solved, not related to AEM or S7 config.

Answers (0)