Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM as cloud - Asset collection errors in log

Manpreetkaur908
Level 1
Level 1

Hi Team,

We are working in assets as cloud project and are noticing multiple errors in logs related to collections.

The number of such errors is quite significant and we suspect if it might not be related to any manual action.

*ERROR* [27.6.223.5 [1627984198406] GET /mnt/overlay/dam/gui/content/commons/createlightbox.html HTTP/1.1] com.day.cq.wcm.tags.IncludeTag Error while executing script ../lightboxassetcount/lightboxassetcount.jsp
javax.servlet.ServletException: Failed executing script /libs/dam/gui/coral/components/admin/collections/lightboxassetcount/lightboxassetcount.jsp: null
at org.apache.sling.servlets.resolver.internal.bundle.BundledScriptServlet.service(BundledScriptServlet.java:82) [org.apache.sling.servlets.resolver:2.7.14]
at com.day.cq.wcm.tags.IncludeTag.includeScript(IncludeTag.java:178) [com.day.cq.wcm.cq-wcm-taglib:5.13.6]
at com.day.cq.wcm.tags.IncludeTag.doEndTag(IncludeTag.java:95) [com.day.cq.wcm.cq-wcm-taglib:5.13.6]
at libs.dam.gui.coral.components.admin.collections.createlightbox.createlightbox__002e__jsp._jspx_meth_cq_include_0(createlightbox__002e__jsp.java:205) [aem-precompiled-scripts:6.6.0.V24469]
at libs.dam.gui.coral.components.admin.collections.createlightbox.createlightbox__002e__jsp._jspService(createlightbox__002e__jsp.java:161) [aem-precompiled-scripts:6.6.0.V24469]

 

Any lead or pointer would be highly appreciable.

 

Regards,

Manpreet

2 Replies
diksha_mishra
Community Advisor
Community Advisor

@Manpreetkaur908 The error talks about a failed script

Have you customized the lightbox or this is OOTB lightboxassetcount.jsp?

Can you check any gaps in code to understand why the file BundledScriptServlet.java, line 82 is not working as expected?

 

manpreetk908
Level 4
Level 4

Hi @diksha_mishra,

 

My apologies, I completely missed your reply.

 

We have not customized collections and were able to narrow down this issue further. It was occurring with few locally created AEM users only. Such users have the right permissions to access assets and collections and were able to create collections when they were created some 2 weeks before this issue occurred. Strangely, it kind of looks like these users got corrupted even though there was no manual modification on such users. Also, if we re-create similar user and assign them the same permissions again, we don't observe these errors.

 

Regards,

Manpreet