Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Win 10 UAP: Not recording lifecycle metrics

gary_lappin
Level 1
Level 1

Hi,

  We have an existing iOS app that we are now creating a Windows 10 UAP version of and i'm looking to add the same lifecycle metrics to it.
I've followed the instructions as follows:

 - Downloaded the Windows 10 UAP SDK and added a reference to it to my project
 - Downloaded 'ADBMobileConfig.json' and added it to the project. No need to configure it further as it is the same one as the iOS app.
 - Added the appropriate calls to 'ADBMobile.Config.CollectLifecycleData()' in App.xaml.cs
 - Enabled debugging ( ADBMobile.Config.SetDebugLogging(true);) so i can view what is being logged

The app compiles and runs and CollectLifecycleData is being called but the only results on the website are for iOS. Any idea what i'm missing?

 Thanks,
   Gary.

1 Accepted Solution
steve_benedick
Correct answer by
Employee
Employee

Hey Gary,

Can you please post the debug log here?

A couple of things you can check: 

  • Have you connected your device to a proxy to see if hits are leaving the device?  
  • Have you tried sending in any other data to your report suite from your UWP app?    

Thanks!

steve benedick

sr mobile software engineer

Adobe Marketing Cloud

View solution in original post

1 Reply
steve_benedick
Correct answer by
Employee
Employee

Hey Gary,

Can you please post the debug log here?

A couple of things you can check: 

  • Have you connected your device to a proxy to see if hits are leaving the device?  
  • Have you tried sending in any other data to your report suite from your UWP app?    

Thanks!

steve benedick

sr mobile software engineer

Adobe Marketing Cloud

View solution in original post