Page hits showing up for iOS but not for Android

cory_smith1

15-10-2015

I'm setting up analytic tracking for an iOS app and and Android app.  In my testing I'm seeing results on the website for the iOS page hits but not the Android ones.  Here are samples of the calls:

iOS (working)

http://omni.pemco.com/b/ss/pemcopemcoqa/0/OIP-3.1.5/

AQB=1
ndh=1
pageName=iPhone.MyInsuranceMenu
ce=UTF-8
vid=4A0E6FEA0439504DC30982F010726A5C03B6
c.=
a.=
DeviceName=x86_64
Resolution=640x1136
OSVersion=iOS%207.0.3
CarrierName=%28null%29
.a=
demoMode=Y
.c=
t=11/10/2013%2011%3A7%3A37%201%20480
AQE=1

 

Android (not working)

http://omni.pemco.com/b/ss/pemcopemcoqa/0/JAVA-4.0.0-AN

AQB=1
ndh=1
pageName=Android.MyInsuranceMenu
t=00%2F00%2F0000%2000%3A00%3A00%200%20300
aid=081B88F45EE64570-164E08FF57E90A41
ts=1384196376
ce=UTF-8
c.=
demoMode=Y
a.=
AppID=Go%20PEMCO%2F1.0
DeviceName=Android%20SDK%20built%20for%20x86
Resolution=768x1184
OSVersion=Android%204.3
CarrierName=Android
.a=
.c=
AQE=1

 

I suspect the "t=" parameter because it looks like it contains valid timestamp info in the iOS call, but not in the Android call.  I have no idea how to configure this in the Android 4.x API.

Can anyone help me out?

Accepted Solutions (1)

Accepted Solutions (1)

meatcouch

Employee

15-10-2015

Cory,

The iOS hits are not timestamped (i.e., offlineTracking is set to false), whereas your Android hits are timestamped (meaning offlineTracking is set to true).  The reason you're seeing data for one and not for the other is due to the fact that the report suite configuration must matched the implementation(timestamped report suites must have the library configured for offlineTracking=true, and vice-versa for non-timestamped).

In the hits you posted,  the timestamp variable is actually ts, the t variable is only used for timezone, which is why you'll see that variable mostly blank on the newer versions of the library. 

You will need to update your Android .json config file to disable offlineTracking and you should start seeing data.

 

Regards,

Peter Fransen

Adobe Marketing Cloud - Mobile Engineering Team Lead

Answers (6)

Answers (6)

meatcouch

Employee

15-10-2015

Jeff,

Please open a ticket with Client Care so we can get this issue resolved for you.

 

Regards,

Peter Fransen

Adobe Marketing Cloud - Mobile Engineering Team Lead

_jeffleong

15-10-2015

Thanks Peter.  Verified with CC and the report suites are not time stamp enabled as well as confirmed that ts is not enabled. 

Any other ideas on what could be causing no data to return with enabling SSL?

meatcouch

Employee

15-10-2015

Jeff,

 

Are you sending the data to the same report suite as qa/dev/stage, or are you switching the targeted report suite at the same time?  If so, you may have a timestamp/offline mismatch (Just like Cory did above).  

 

In cases like this it may be a faster resolution for you to contact Client Care directly, as they have access to the details on your account and can discuss in more specific terms.

 

Regards,

Peter Fransen

Adobe Marketing Cloud - Mobile Engineering Team Lead

_jeffleong

15-10-2015

Hi Cory, 

Experiencing the same problem, but with 3x on Android.  We've setup a non-SSL for qa/dev/stage, but when pushing to prod, all properties (including web, mobile web and for this app), SSL is enabled.  When SSL is enabled, no data is received by SiteCatalyst.  When switched to non-SSL data is recieved.  Would you happen to have any ideas on what could be causing this?

SSL Request:

                                                                                                             
AQB1
ndh1
ceUTF-8
videfa811eccbf548a996f20e21e9e889d3
pev2ADMS BP Event
t22/10/2013 15:17:37 5 480
c. 
a. 
HourOfDay15
Resolution1200x1824
MonthlyEngUserEventMonthlyEngUserEvent
InstallEventInstallEvent
EngDaysLifetime+1
DailyEngUserEventDailyEngUserEvent
InstallDate11/22/2013
AppIDWestJet(1.0)
OSVersionAndroid 4.3
Launches1
DeviceNameNexus 7
DayOfWeek6
OSEnvironmentAndroid 4.3
LaunchEventLaunchEvent
.a 
.c 
pageNameWestJet(1.0) Install
pelnk_o
AQE1

Non-SSL

                                                                                                     
AQB1
ndh1
ceUTF-8
videfa811eccbf548a996f20e21e9e889d3
pev2ADMS BP Event
t25/10/2013 13:36:9 1 480
c. 
a. 
DaysSinceFirstUse2
OSVersionAndroid 4.3
HourOfDay13
Resolution1200x1824
PrevSessionLength1
Launches7
DeviceNameNexus 7
DaysSinceLastUse0
DayOfWeek2
OSEnvironmentAndroid 4.3
LaunchEventLaunchEvent
AppIDWestJet(1.0)
.a 
.c 
pageNameWestJet(1.0) Launch
pelnk_o
AQE1

Thanks in Advance