Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Mobile App Analytics - Error on Port

anudeep_srivas1
Level 2
Level 2

Hi , 

I am trying to implement mobile app Analytics  through Mobile Services SDK by provided sample app , It has only worked for me once where I was able to see some hits in Blood hound post which nothing is working out and I am not able to see image request at all . 

I have tried to put up a logger to see whats happening and this is what I am always seeing : 

02-08 17:22:51.205    8429-8452/? D/ADBMobile﹕ ADBMobile Debug : Analytics - Attempting to send request parameters
(ndh=1&ts=1454932371&ce=ISO-8859-1&c.&a.&DeviceName=Lenovo%20A7000-a&TimeSinceLaunch=10
&OSVersion=Android%205.0&Resolution=720x1280&CarrierName=Airtel
&AppID=SDK%20Samples%201.0%20%281%29&.a&.c&t=00%2F00%2F0000%2000%3A00%3A00%200%20-330&page Name=Gallery&aid=48222252377949F7-2C014C1E89E6A505)

02-08 17:22:51.294    8429-8496/? D/Posix﹕ [Posix_connect Debug]Process com.adobe.adbmobilesamples :80
02-08 17:22:51.305    8429-8495/? D/Posix﹕ [Posix_connect Debug]Process com.adobe.adbmobilesamples :80
02-08 17:23:11.847    8429-8460/? D/Posix﹕ [Posix_connect Debug]Process com.adobe.adbmobilesamples :50000

02-08 17:23:11.848    8429-8460/? D/ADBMobile﹕ ADBMobile Debug : Analytics - IOException while sending request, 
may retry(failed to connect to localhost/127.0.0.1 (port 50000) after 5000ms: isConnected failed: ECONNREFUSED (Connection refused))

02-08 17:23:11.848    8429-8460/? D/ADBMobile﹕ ADBMobile Debug : Analytics - Network error, imposing internal cooldown(30 seconds)

Can someone please help me out here ??

I have even attached bloodhound image too in this 

1 Accepted Solution
steve_benedick
Correct answer by
Employee
Employee

Hey Anudeep Srivastav ,

It looks like your device/emulator isn't able to communicate with your Bloodhound instance.  I would double-check your ADBMobileConfig.json file to verify it's pointing at the IP Address of your Bloodhound proxy.  Hope this helps.

steve benedick

sr mobile software engineer

View solution in original post

2 Replies
steve_benedick
Correct answer by
Employee
Employee

Hey Anudeep Srivastav ,

It looks like your device/emulator isn't able to communicate with your Bloodhound instance.  I would double-check your ADBMobileConfig.json file to verify it's pointing at the IP Address of your Bloodhound proxy.  Hope this helps.

steve benedick

sr mobile software engineer

View solution in original post

anudeep_srivas1
Level 2
Level 2

Hi Steve , 

I have corrected it , I did a mistake of not changing Server in ADBMobileConfig.json file to blood hound proxy . 

I am able to see data in Blood Hound now .. 

Thanks for the help .. 

Regards

Anudeep