Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

iOS SDK aquisition request not send via https (fails with iOS 9)

sebastian_ostho
Level 1
Level 1

When using the Adobe SDK 4.5.5 we see that the acquisition: server and appid properties from the configuration ADBMobileConfig(Dev/Prod).json are composed to a http://server/appid url.
On iOS 9 however the http request will only result in a faulty response as Apple is enforcing https (TLSv1.2) connections throughout the App.
This would result in “stuff”, “uuid” and “dcs_region” to be not properly fetched.

 

All other requests fired by the Adobe SDK properly connect to the specified https endpoind.

Are we doing something wrong in configuring the initial request or is there an update scheduled?

1 Accepted Solution
TanmayMathur
Correct answer by
Level 10
Level 10

Hi, 

Your question would require a look into your implementation to be properly answered. I would suggest it would be a good idea to reach out to ClientCare and have it debugged. Apologies for the delayed response.

Thanks and Regards,

TM

View solution in original post

1 Reply
TanmayMathur
Correct answer by
Level 10
Level 10

Hi, 

Your question would require a look into your implementation to be properly answered. I would suggest it would be a good idea to reach out to ClientCare and have it debugged. Apologies for the delayed response.

Thanks and Regards,

TM

View solution in original post