Campaign SDK Version Coming as Null

Avatar

Avatar

mcece01

Avatar

mcece01

mcece01

12-01-2021

I am using multiple Adobe Launch extensions like:

Target.registerExtension()
Analytics.registerExtension()
Identity.registerExtension()
Lifecycle.registerExtension()
Signal.registerExtension()
UserProfile.registerExtension() 

When we try to use campaign extension for push messaging, I added

Campaign.registerExtension()

as well. I also added implementation:

implementation "com.adobe.marketing.mobile:campaign:1.+"

 However, I am getting this log;

 

V/AdobeExperienceSDK: EventHub(AMSEventHub) - Registering extension 'com.adobe.module.campaign' with version 'null'

and 

V/AdobeExperienceSDK: EventHub(AMSEventHub) - New shared state data for 'com.adobe.module.eventhub' at version '0':
{
"extensions" : {
"Target" : {
"version" : "1.1.6"
},
"Signal" : {
"version" : "1.0.2"
},
"Configuration" : {
"version" : "1.5.7"
},
"UserProfile" : {
"version" : "1.1.0"
},
"com.adobe.module.campaign" : {
"version" : ""
},
"Lifecycle" : {
"version" : "1.0.6"
},
"Identity" : {
"version" : "1.2.2"
},
"Analytics" : {
"version" : "1.2.6"
}
},
"version" : "1.5.7"
}

 

How can I fix this issue? 

Adobe Campaign Adobe Campaign Standard

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar

Ivan_Mironchuk

Employee

Avatar

Ivan_Mironchuk

Employee

Ivan_Mironchuk
Employee

12-01-2021

Did you also make sure to import the campaign extension in your project? I see the implementation for your cradle file and also the register call. 

Make sure to match the sample on this page below. Also note that the extension version can be called using;

 

Campaign.extensionVersion();

 

https://aep-sdks.gitbook.io/docs/using-mobile-extensions/adobe-campaign-standard