Highlighted

ad-hoc builds won't complete unless Bitcode is disabled

dbtrade

19-03-2019

Recently updated to version 4.18.0 and now cannot build an ad-hoc build

Products/Debug-iphoneos/AdobeMobileSDK/AdobeMobileSDK.framework/AdobeMobileSDK' was built without full bitcode. All frameworks and dylibs for bitcode must be generated from Xcode Archive or Install build file "

This is a new error for us with this upgrade. Has anyone seen this or know a workaround?

Replies

Highlighted

steve_benedick

Employee

19-03-2019

Hey dbtrade,

I have been unsuccessful in trying to reproduce this issue.  Would you mind sharing more information about your environment? 

  • What version of Xcode are you using?
  • Is this a Swift or Obj-c app?
  • Looks like you're using the Cocoapod, can you confirm?  If so, would you mind sharing your Podfile?
  • What settings are you enabling when building your Ad Hoc distribution?

Thanks.

Steve Benedick

Sr. Mobile Engineer

Adobe Experience Cloud

Highlighted

dbtrade

22-03-2019

Thanks for your quick response, I have not been so speedy.

Answers to your questions:

  • What version of Xcode are you using?

Version 10.1 (10B61)

  • Is this a Swift or Obj-c app?

mixed.

  • Looks like you're using the Cocoapod, can you confirm?  If so, would you mind sharing your Podfile?

Yes, we are using Cocoapod. v 1.6.1. 
What's the recommended way of sharing the pod file? Or do you mean pasting the relevant portions?

  • What settings are you enabling when building your Ad Hoc distribution?

Not sure which ones you are looking for, but we have Enable Bitcode on for for Debug, Release, Distribution in Build Settings


Thanks for your help.