Sharing Audience with Target

Avatar

Avatar

kanchanmitha

Avatar

kanchanmitha

kanchanmitha

04-09-2018

Hi all,

Recently I implemented target on my website using DTM. Website has experience cloud implementation.

I am facing an issue with audience sharing between analytics and target. Segment been created in analytics is visible in target as audience but somehow a valid user is not fulfilling the criteria of audience in target only.

I have verified target calls.. they do contain marketing cloud visitor id. It seems I missed some part somewhere in visitor syncing but not able to identify.

Need immediate help in  resolving this .

Thanks in advance.

Accepted Solutions (0)

Answers (12)

Answers (12)

Avatar

Avatar

kanchanmitha

Avatar

kanchanmitha

kanchanmitha

07-03-2019

Hi,

This issue was closed by adobe as data started populating after 5th day but was not able to get a valid explanation from them regarding why it took so much time for audience to be reflected in target.

Because of the delay in data availability we stopped using the approach.

Avatar

Avatar

kanchanmitha

Avatar

kanchanmitha

kanchanmitha

12-09-2018

Hi Kenelson

Thanks for replying.

I have raised this issue with client care. They have validated that segment is fine and it is sharing visitors with experience cloud. But why that count is not reflecting in audience. He is not sure about it. So, it is open at engineering end.

Will update the thread when get a solution from engineering team.

Regards

kanchanmitha

Avatar

Avatar

skandg43264764

Avatar

skandg43264764

skandg43264764

06-09-2018

When a segment is created in Analytics and then shared with marketing cloud.

You have to ensure the qualification condition are all met when user is visiting the page.

Once a visitor qualifies for the audience shared from Analytics, there is a 24 - 48 hour delay before that information is actionable in Target.

Regards

Skand Gupt

Avatar

Avatar

chrisw27896218

Avatar

chrisw27896218

chrisw27896218

07-03-2019

This is semi-related to this post.

I have noticed a similar issue but it seems it's due to the 24-48 hour delay... This seems like a huge amount of time! I was hoping to use a segment to catch a user within a current session (whether they'd visited a certain page) - but it won't even register they hit the page for up to 72 hours? What if they never return to the site... Is the only way to get instant feedback to use Profile Scripts and Target based audiences?

Avatar

Avatar

jantzen_belliston-Adobe

Community Manager

Total Posts

1.9K

Likes

312

Correct Answer

570

Avatar

jantzen_belliston-Adobe

Community Manager

Total Posts

1.9K

Likes

312

Correct Answer

570
jantzen_belliston-Adobe
Community Manager

24-01-2019

Did you ever find out the root cause of this issue?

Avatar

Avatar

Kenelson2

Employee

Avatar

Kenelson2

Employee

Kenelson2
Employee

12-09-2018

Soon as you can get us the details we can look further into the issue as Skand has mentioned. Also if you can PM either Skand, myself or settyb one of us will be able to look into this issue see what is going on exactly. Steps to replicate would be awesome and plus include in your PM the name of the Cloud, and segment you are looking at in Target.

Best,

Kerry

Avatar

Avatar

skandg43264764

Avatar

skandg43264764

skandg43264764

11-09-2018

You can get access to People-> Audience Library by requesting access from System admin of your Marketing Cloud and then you can validate the audience if it is still collecting data or not ?

You can share the website URL and explain steps to reproduce to us, so that we can also take a look into it.

Avatar

Avatar

kanchanmitha

Avatar

kanchanmitha

kanchanmitha

09-09-2018

Hi settytb

I do not have people access for current account so cannot tell exact state for audience.

But as mentioned in above message, tested this in another account: audience changed its state from collecting data to valid count in 5 days.

Thanks & Regards

kanchanmitha

Avatar

Avatar

kanchanmitha

Avatar

kanchanmitha

kanchanmitha

09-09-2018

Hi Jantzen.Belliston,

Thanks for replying.

I have validated the user id in analytics using the same segment.

I visited the website myself and made myself a valid user for target activity but still after this long time somehow in target user is not able to qualify for it.

As I do not have audience library access in this account so to validate the scenario further I tried similar activity in another account. In this account I am able to see data after 5 days for one segment.

Are there any more steps that one need to validate for this implementation.

Regards

kanchanmitha

Avatar

Avatar

settytb1

Employee

Avatar

settytb1

Employee

settytb1
Employee

07-09-2018

Yeah, the timeline is most important.  You would need to on day 1 go to the site and meet the criteria of the segment.  From there Analytics will export the segment data to the cloud.  Then it gets processed and sent to target.  From there ~48-72 hours later, you would then need to go back to the page with the same MID and you should be qualified at that point.  So, you can't really test with like an incognito window because the mid would be cleared before the 72 hours are up.  If you look in Audience Library in the Cloud (Click the 9 dots and click on the people item).  Do you see the audience size in there and does it have visitors in it? 

I hope that helps,

Seth

Avatar

Avatar

jantzen_belliston-Adobe

Community Manager

Total Posts

1.9K

Likes

312

Correct Answer

570

Avatar

jantzen_belliston-Adobe

Community Manager

Total Posts

1.9K

Likes

312

Correct Answer

570
jantzen_belliston-Adobe
Community Manager

07-09-2018

Hi Kanchan,

When you say no user is qualifying, how are you testing this? Are you viewing the audience size in Target? Are you trying to qualify yourself? or is there another method you're using to test this?

Also, have you run an Auditor scan by chance? This will help us check that your code versions are up to date and that the variables are being passed between solutions correctly. For example, we need to make sure the Analytics calls used to qualify for the audience all contain a consistent MID value. We also need to make sure Target has the same value in it's request. I believe Target uses the MCGVID as the parameter name.

These are a few quick thoughts but we may need to dive a bit deeper. If you can provide a URL with steps to qualify for the audience we may be able to try and replicate. Also we may want to involve customer care so they can look into your account and view the audience and verify that it's being passed from Analytics to Target correctly.

Thanks,
Jantzen

Avatar

Avatar

kanchanmitha

Avatar

kanchanmitha

kanchanmitha

06-09-2018

Hi Skand,

Thanks for replying but its been 1 week and still no user is qualifying for it.I have followed all the steps mentioned in documentation.

Regards

Kanchan Mitharwal