Expand my Community achievements bar.

SOLVED

How to track progress Adobe Commerce Events I/O?

Avatar

Level 2

Hi all, please help me

 

1) I created an event as in the documentation:

bin/magento events:info plugin.magento.catalog.api.category_repository.save

bin/magento events:subscribe observer.catalog_category_save_after --fields=entity_id --fields=parent_id

cat app/etc/config.php

...
    'io_events' => [
        'observer.catalog_category_save_after' => [
            'fields' => [
                'entity_id',
                'parent_id'
            ],
            'enabled' => 1
        ]
    ]
...


2) Next, according to the documentation, I connected the event

account.png

 

 

3) In the event_data table I see that status = 1, which means that the event has been sent

 

4) In system.log

report.INFO: Event data batch of 1 events was successfully published. [] []

5) xDebug receives a response that the event was sent successfully.

response.png

 

6) But it doesn't come to my microservice and I can't get it in the Event Browser tab.

debug.png

 

debug_tracing.png

 

Questions:
1) Why the event does not come to the developer console ?
2) Why the event does not arrive in the microservice ?
3) How can I find an event after it was sent from Adobe Commerce?

 

Eugene,

Kapelko

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi @Eugene_Kapelko. Following up on this question - can you confirm that the provider configured in the Commerce admin is the same as the provider for that event registration?

 

(You can check the provider id for the registration's events to see if it matches the provider id set in the Commerce admin using the 'aio event registration get <registration_id>' command)

View solution in original post

3 Replies

Avatar

Employee

Hi @Eugene_Kapelko, Can you please share the event registration URL from developer console? I noticed you have masked out those details but having the URL would be helpful for us to debug.

 

Also what is the documentation you are referring to?


1) I created an event as in the documentation:

 

Avatar

Correct answer by
Employee

Hi @Eugene_Kapelko. Following up on this question - can you confirm that the provider configured in the Commerce admin is the same as the provider for that event registration?

 

(You can check the provider id for the registration's events to see if it matches the provider id set in the Commerce admin using the 'aio event registration get <registration_id>' command)

Avatar

Level 2

Hello @shikhartanwar , @RyanCo5 ,

 

Thank you for the answers you provided and the options you mentioned.

The problem was that the instance ID in Adobe Commerce was different from the instance ID for the event in Adobe Developer Console.

To solve this I removed the event from the Adobe Developer Сonsole.
And I re-synchronized the event and settings (instance ID and provider ID) in Adobe Commerce and in the Adobe Developer Console.

After that, I added an event to the Adobe Developer Console and everything worked.

 

Regards,

Eugene