xtk:session:Write to extened table.

Avatar

Avatar
Validate 10
Level 4
davidl14970702
Level 4

Likes

30 likes

Total Posts

93 posts

Correct reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 4
davidl14970702
Level 4

Likes

30 likes

Total Posts

93 posts

Correct reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
davidl14970702
Level 4

27-08-2018

Im not sure why this is not writing to the targeted table.

If I update xtkschema for the recipient table it works fine.

Any help would be great.

var table = <recipient

               xtkschema="lw:gospelCurriculumTmpTbl"

                _operation="insert"

               _key="@recipientId"

               recipientId="11111111"

               email="loyd.write@apitest.com"

               />;          

xtk.session.Write(table);

logInfo("---fin---")

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 10
Level 4
davidl14970702
Level 4

Likes

30 likes

Total Posts

93 posts

Correct reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 4
davidl14970702
Level 4

Likes

30 likes

Total Posts

93 posts

Correct reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
davidl14970702
Level 4

28-08-2018

I found the problem.

my table is not an extension of the recipient table. I changed the XML tag to reflect the name of my table and my data showed up.

This resource was helpful in understanding what was happening.

Introduction

Answers (2)

Answers (2)

Avatar

Avatar
Validate 10
Level 4
davidl14970702
Level 4

Likes

30 likes

Total Posts

93 posts

Correct reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 4
davidl14970702
Level 4

Likes

30 likes

Total Posts

93 posts

Correct reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
davidl14970702
Level 4

28-08-2018

I am running this in a workflow currently.

When it run's I don't get any errors back. But I'm not seeing data on the table as I would expect.

Initially, I thought xtkschema="lw:gospelCurriculumTmpTbl" was an extension of the recipient table but after checking I think it is it's own stand-alone table.

<srcSchema _cs="Gospel Curriculum Temp table (lw)" created="2017-10-25 11:52:24.480Z"

           createdBy-id="0" desc="Gospel Curriculum Temp table" entitySchema="xtk:srcSchema"

           img="xtk:schema.png" label="Gospel Curriculum Temp table" labelSingular="Gospel Curriculum Temp table"

           lastModified="2017-10-25 11:52:24.479Z" mappingType="sql" md5="657196B364BDDC620B5B21E5289D89B6"

           modifiedBy-id="0" name="gospelCurriculumTmpTbl" namespace="lw" xtkschema="xtk:srcSchema">

Avatar

Avatar
Give Back
Employee
anshshar
Employee

Likes

2 likes

Total Posts

10 posts

Correct reply

2 solutions
Top badges earned
Give Back
Boost 1
Affirm 1
View profile

Avatar
Give Back
Employee
anshshar
Employee

Likes

2 likes

Total Posts

10 posts

Correct reply

2 solutions
Top badges earned
Give Back
Boost 1
Affirm 1
View profile
anshshar
Employee

28-08-2018

Hi David

Can you share the error that you are getting using above sample?

If you are running this in a workflow (good idea for testing) you can activate the workflow property to log SQL queries in the journal to see where exactly it is failing.

Additionally, I see schema selected is xtkschema="lw:gospelCurriculumTmpTbl" . Can you confirm by any chance if this one is an extension of any other schema ?

Regards

Anshul