Using JQuery in Adobe Campaign WebApp

Avatar

Avatar

sagil23995776

Avatar

sagil23995776

sagil23995776

04-12-2017

Hi,

Is it possible to use a JQuery function in Adobe Campaign web application?

When I try to use one and preview the app I get a script error saying

'$' is undefined. Obviously I can't use JQuery without the dollar symbol.

Is there a way to bypass this?

Thanks,

Sagi

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

david_garcia1

MVP

Avatar

david_garcia1

MVP

david_garcia1
MVP

10-12-2017

Hi Vipul whats the difference between 8886 and 8887

@OP in your code you can replace "$" by "jQuery" and the code should work.

Answers (5)

Answers (5)

Avatar

Avatar

sagil23995776

Avatar

sagil23995776

sagil23995776

10-12-2017

Thanks David that worked

Sagi

Avatar

Avatar

Vapsy

Employee

Avatar

Vapsy

Employee

Vapsy
Employee

10-12-2017

Hi Sagil,

Quite possible your instance is impacted because of the same bug.

I would recommend upgrading to atleast 8770, however, we have the latest build 8887 available these days.

Regards,
Vipul

Avatar

Avatar

sagil23995776

Avatar

sagil23995776

sagil23995776

10-12-2017

Hi Vipul,

I'm using version 6.1.1 build 8754

server version 6.1.1 build 8754

Avatar

Avatar

Vapsy

Employee

Avatar

Vapsy

Employee

Vapsy
Employee

08-12-2017

Hi Sagi,

Can you please confirm which build you are on.

There was similar regression found in build 8766 which was fixed in build 8770.

Maybe you are impacted because of it.

Regards,
Vipul

Avatar

Avatar

florentlb

Avatar

florentlb

florentlb

08-12-2017

Hi Sagi,

I'm not sure it is possible. Though I cannot confirm 100% right now since I'm not very familiar with such cases.

Let me know if you find a solution in the meantime,

Florent