Unable to publish offers on the Web channel (Inbound Web Offer Space) - Interaction

sharma15

04-10-2016

Hi,

I have published one offer space (Inbound Web Recipient New) and  2 offers in the offer catalog. The eligibility criteria of my offers depends on my interaction schema columns. 

I followed the documentation and created a HTML page with the interactionProposalScript and server details.

Also included a <div> tag to refer to my offer space. 

<div id="i_inboundWebNew">
        </div>

<script id="interactionProposalScript" src="http://ac167us.adobedemo.com/nl/interactionProposal.js?env=liveRcp&cb=alert" type="text/javascript">
        </script>    

I included a interactionGlobalCtx variable to pass my interaction value. 

When I run this HTML , it gives me an error. It says <propositions> The offer space with the key hasn't been published. I have attached the screenshot.

 

Please help me with the same. 

 

Thanks.

Accepted Solutions (1)

Accepted Solutions (1)

florentlb

10-10-2016

Hi,

Considering that the option is checked and the offer space correctly deployed, the issue may come from the HTML If the offer space is not found, that suggests that is does not call the intended one.

Do you have a way to check this ?

Please let me know if you find any solution.

Florent.

Answers (9)

Answers (9)

romainr89040357

13-09-2017

Hello,

I'm having the same problem...

At first I saw the technical workflow was in error (index problem). We solved it and restarted the workflow. It now never finishes...
I can see some logs but I don't know why the js activity still blinks... (the "go-live" one)...

Need help... Interaction module is a labyrinth...

Martonbot

26-04-2017

Hi Parmeshwar,

 

First think that comes to my mind is, try restarting the interactiond module (nlserver restart interactiond) if you have access to the application server.

If this doesn't work, there is a technical workflow under Administration -> Production -> Technical workflows -> Campaign process -> Offer notification that you can try to re-run manually.

Let me know if  that does the trick for you.

 

Cheers,

Martin

parmeshwar

23-04-2017

Hi Martin,

Could you please tell how you have resolved the issue ?

For me also the 'Publish' option is not enabled.

It will be very helpful.

Thanks.

Parmeshwar 

Martonbot

18-01-2017

Hi,

I'm having the exact same issue. I have created an offer space in the Design environment, and then I went right click -> Deploy to the Live environment.

But I get the same error message when trying to get an offer from a web page: "The offer space with the 'liveRcp|demoWeb' key hasn't been published."

If someone solved this one, I would be interested in the solution.

Thanks!

Martin

PS: if I right-click on the offer space -> Actions, I can see the Publish option but it's grayed (see attached screenshot).

florentlb

04-10-2016

Hello,

I have got some more information about what could have gone wrong with the offer space.

As mentioned in step 3 in documentation, can you check that the "Enable unitary mode" option is correctly checked in the offer space and try to deploy it again to live environment?

Thanks,

Florent

florentlb

04-10-2016

Hello,

I'll check if this kind of issue is known and if there is a common way to fix it. I'll post an answer as soon as I get the info.

In the meantime, can you double check that everything is published as it should in the live environment?

Thanks,

Florent.