Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Unable to load document of identifier 'temp:query6' and type 'xtk:schema'

Avatar

Avatar
Validate 1
Level 1
MeMonty
Level 1

Likes

4 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 1
MeMonty
Level 1

Likes

4 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
MeMonty
Level 1

10-03-2017

Hi,

I have built a workflow with a single query based on a single table. I have run the workflow and it shows some count (of records) in the result. When I used “Display the target” (in the context menu by right clicking on the Result arrow) to see the Result, I am getting the following error.

The edit from initialization has failed

Unable to load document of identifier 'temp:query6' and type 'xtk:schema'

Could you please advise.

Regards,

Mahantesh

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Employee
Vapsy
Employee

Likes

369 likes

Total Posts

726 posts

Correct Reply

342 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
Employee
Vapsy
Employee

Likes

369 likes

Total Posts

726 posts

Correct Reply

342 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Vapsy
Employee

13-03-2017

Hi Mahantesh,

This error is coming because your workflow must be in a Finished State.

Can you please right click on the destination activity of the transition data that you are trying to preview, select Enable but do not execute.

Now rerun the workflow followed by Display the target.

Regards,

Vipul

Answers (5)

Answers (5)

Avatar

Avatar
Validate 1
Employee
Vapsy
Employee

Likes

369 likes

Total Posts

726 posts

Correct Reply

342 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
Employee
Vapsy
Employee

Likes

369 likes

Total Posts

726 posts

Correct Reply

342 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Vapsy
Employee

10-03-2017

Hi Mahantesh,

Please can you try the following:

  1. Clear cache from console followed by logout and login.
  2. Hard cache clear followed by logout and login.
  3. When you have the display taret window open, can you apply a filter condition from the filter menu at top. Condition can be as simple as @id not equal to 0

Please try and see if it helps.

Regards,

Vipul

Avatar

Avatar
Boost 1
Level 2
SamitJain
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

5 solutions
Top badges earned
Boost 1
Affirm 5
Affirm 3
Affirm 1
View profile

Avatar
Boost 1
Level 2
SamitJain
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

5 solutions
Top badges earned
Boost 1
Affirm 5
Affirm 3
Affirm 1
View profile
SamitJain
Level 2

01-05-2017

Hello,

Please follow the below steps:

Hard Cache clear

For Windows 7 OS

  • Logout and close Adobe Campaign console (rich client)
  • Go to C:\Users\<username>\AppData\Roaming\Adobe Campaign\NL_5\
  • Here you will see many xml file named “nlclient-config-<alphanumerical value>.xml”. Please delete these xml file and associated folders, but making sure you do NOT delete “nlclient_cnx.xml”
  • Login to Adobe Campaign console

For Windows XP OS

-      Same instructions applied but files are located in the following location

In C:\Documents and Settings\<username>\Application Data\Adobe Campaign\NL_5

Thanks,

Samit

Avatar

Avatar
Level 1
kbint
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
kbint
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
kbint
Level 1

01-05-2017

Hi  Vipul,

Can you explain how to 'hard clear cache'?  I cleared console cache a number of times and am still receiving error when trying to 'Display the Target' on any activity in my workflow.  Data is passing through, but I can't view it.  Receiving

"Unable to read data from the base, the table has been purged or the current workflow configuration is no longer compatible with its structure".

Please help.

Thanks in advance.

KB

Avatar

Avatar
Validate 1
Level 1
MeMonty
Level 1

Likes

4 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 1
MeMonty
Level 1

Likes

4 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
MeMonty
Level 1

13-03-2017

Hi Vipul,

Thanks for your response.

Yes, it worked.

Regards,

Mahantesh

Avatar

Avatar
Validate 1
Level 1
MeMonty
Level 1

Likes

4 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 1
MeMonty
Level 1

Likes

4 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
MeMonty
Level 1

13-03-2017

Hi Vipul,

Thanks for your response. I did as you mentioned and the error I had mentioned has gone but it is giving a different error now.

Unable to read data from the base, the table has been purged or the current workflow configuration is no longer compatible with its structure.

Display errors during data loading...

When I clicked on this link, it is showing the detailed error message

PostgreSQL error: ERROR: relation "wkf1031459404_8_1" does not exist

LINE 1: ...(' || COALESCE(O1.sInternalName, '') || E')' FROM wkf1031459...

  ^

SQL statement 'SELECT   W0.iId, W0.iCampaignId, W0.sCampaignLabel, W0.iCampaignType, W0.dCampaignDuration, W0.iCampaignCancelStatus, W0.iCampaignState, W0.tsCampaignCreation, W0.tsCampaignLastModified, W0.tsCampaignStart, W0.tsCampaignEnd, COALESCE(O1.sLabel, '') || E' (' || COALESCE(O1.sInternalName, '') || E')' FROM wkf1031459404_8_1 W0 JOIN NmsOperation O1 ON (O1.iOperationId = W0.iId) LIMIT 200' could not be executed.

  Unable to complete operation in current state.

Could you please advise.

Regards,

Mahantesh