'temp:query' schema not defined error while report preview

michalm8735546

20-10-2017

Hi everyone,

I'm trying to preview a report based on an imported list and I'm getting this error message:

XTK-170024 The temporary 'temp:query' schema is not defined in the current context. SOP-330011 Error while executing the method 'ExecuteQuery' of service 'xtk:queryDef'.

It's nothing complicated, I'm just trying to complete the Campaign hands-on lab, following exact instructions and without the report I can't proceed.

This is the report workflow:

Screenshot (5).png

And this is the workflow where I generated the list the report is based on.

Screenshot (3).png

Any ideas on how to resolve this? Thanks.

Michal.

Accepted Solutions (1)

Accepted Solutions (1)

Jean-Serge_Biro

MVP

20-10-2017

Hi Michal,

I reproduce the same issue as you, whenever selecting List radio button choice. I guess there is a bug in Report module for List, because I tried with Lists with other target dimension schema than recipients and it occurs the same error.

Please take the time to create a bug report on Adobe Campaign extranet web site.

In the meanwhile, please use this workaroung, I tried it and it works fine for me; in Report app Query activity:

1. choose the 1st Radio button: Database schema

2. select the schema of your lists content (rcpGrpRel if the target dimension is NmsRecipient)

3. select the fields for your temp:query context

4. do your selection of List(s) in the linked dimension with help of Internal name (or other criteria) or on the root dimension link to select one list

Regards
J-Serge

Answers (2)

Answers (2)

michalm8735546

20-10-2017

Hi Jean,

thanks for the reply.

Here is the screenshot of the query settings, "undefined" is just a label - instructor in the video also has it like that, so I don't think that's the problem.

Screenshot (6).png

Jean-Serge_Biro

MVP

20-10-2017

Hi Michal,

Please may you share a screenshot on the Query activity settings? Because the label is "undefined" I guess the query definition might be wrong by selecting the list group with the id or internal name?

Regards
J-Serge