Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

React Native SDK - Framework not found ACPCampaign

Avatar

Avatar
Boost 1
Level 1
lucasmleal
Level 1

Like

1 like

Total Posts

4 posts

Correct Reply

1 solution
Top badges earned
Boost 1
Validate 1
Affirm 1
View profile

Avatar
Boost 1
Level 1
lucasmleal
Level 1

Like

1 like

Total Posts

4 posts

Correct Reply

1 solution
Top badges earned
Boost 1
Validate 1
Affirm 1
View profile
lucasmleal
Level 1

07-05-2021

I'm trying to install the React Native AEP Campaign Standard Extension (https://github.com/adobe/react-native-acpcampaign).

 

After I run 'pod install' I'm getting an iOS build error on Xcode:

lucasmleal_0-1620391412712.png

 

Steps to reproduce:

npm install @adobe/react-native-acpcore
cd ios/ && pod install

npm install @adobe/react-native-acpcampaign
cd ios/ && pod install

Library versions:

react-native: "0.62.2"
@adobe/react-native-acpcore: "1.4.0"
@adobe/react-native-acpcampaign:"1.2.0"
XCode: 12.1

Additional information:

While 'pod install' was running a new warning message showed up, apparently referencing ACPCampaign:

lucasmleal_1-1620391910012.png

"[Xcodeproj] Generated duplicate UUIDs"

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 1
Level 1
lucasmleal
Level 1

Like

1 like

Total Posts

4 posts

Correct Reply

1 solution
Top badges earned
Boost 1
Validate 1
Affirm 1
View profile

Avatar
Boost 1
Level 1
lucasmleal
Level 1

Like

1 like

Total Posts

4 posts

Correct Reply

1 solution
Top badges earned
Boost 1
Validate 1
Affirm 1
View profile
lucasmleal
Level 1

10-05-2021

I upgraded Xcode as @nporter suggested but the issue remained.

 

Fortunately we found the issue in CocoaPods repository and the solution fixed for us too:

https://github.com/CocoaPods/CocoaPods/issues/4370#issuecomment-183205691 

 

Including the following line in our Podfile solved the warning and the error no longer occurs:

install! 'cocoapods', :deterministic_uuids => false

 Anyway, thanks for your time @nporter. I aprecciate your help.

 

Regards,

Lucas. 

Answers (1)

Answers (1)

Avatar

Avatar
Boost 3
Level 1
nporter
Level 1

Likes

3 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile

Avatar
Boost 3
Level 1
nporter
Level 1

Likes

3 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile
nporter
Level 1

07-05-2021

Hi lucasmleal, I attempted to reproduce this issue but wasn't able to. I installed core and campaign into a fresh react native app and everything built without error. Here are the steps I took:

 

react-native init campaignTest && cd campaignTest

npm install @adobe/react-native-acpcore

npm install @adobe/react-native-acpcampaign

cd ios/ && pod install

* open Xcode and build project *

 

For background, I am running Xcode 12.4 and React Native 0.64.1. I have pushed up this sample project here: https://github.com/nporter-adbe/campaignTest

If I had to guess I would suggest upgrading your Xcode version if possible. It may have some compatibility issues with the XCFramework bundled in our packages. Let me know if this resolves your issue.