PostUpgrade failing on "Patching Include Views"

david_garcia1

MVP

10-12-2017

Hi Guys,

I am performing an upgrade on my dev environment from 6.0.2 to 6.1.1. however there is a code block that is failing to compile in the postupgrade.

Below is the codeblock failing to compile while running the postupgrade command, the only way I've been able to come around this is by upgrading to 6.1.1 8687 then to 6.1.1 8770. However, I want to avoid doing this and upgrade straight from 6.0.2 to 8770. I've also tried the latest build 8886 but the upgrade fails on this very codeblock. I was able to validate this by altering the postupgrade script and removing the whole upgrade section for "<from lessThan="7987">" and it was a success, but ideally I'd like the adobe dev team to look into why this code is failing.

Error code:

2017-12-08 01:37:19.612Z    00000AEC      1    error    log    JST-310000 Error while compiling script 'inline' line 3: syntax error (line='var ViralLinkHtmlFr = <![CDATA[<p>\n' token='<![CDATA[<p>\n').

2017-12-08 01:37:19.612Z    00000AEC      1    error    log    SCR-160032 JavaScript: error while compiling script 'inline'. (iRc=-53)

2017-12-08 01:37:19.612Z    00000AEC      1    error    log    CFG-600010 Document update job stopped after an error (iRc=-53)

1370075_pastedImage_1.png

Accepted Solutions (1)

Accepted Solutions (1)

david_garcia1

MVP

18-01-2018

TechOps just said that I should rely on intermediate build upgrades, so it seems like they aren't fixing the issue, instead I am to upgrade to the latest build of each version, which is what I was already doing to get around this problem.

Answers (6)

Answers (6)

david_garcia1

MVP

13-12-2017

Thanks florent,

I've seen the notes previously also, but these are related after a successful postupgrade, so to migrate the missing dropdown stuff for client issues

However, in my case the postupgrade fails, also all security zones have been added and flags for sqlinjection turned to true.

florentlb

13-12-2017

Hi David,

While doing some search, I came across this section which is not visible yet publicly in the docs but will be by the end of this week:

(This is about migrating from 6.02 to 6.11)

---

When migrating from the v.6.02 to Adobe Campaign v6.1 build 8670 or above, then certain files delivered beforehand are not delivered with these builds.

If a client error appears, you have to either update your dashboards with the new Adobe Campaign v6.1 code, or manually copy the following files from the v6.02 instance to the v6.1 instance.

v6.02 files and spaces: 
/usr/local/neolane/nl6/datakit/xtk/eng/css/dropDownMenu.css
/usr/local/neolane/nl6/datakit/xtk/eng/js/client/dropDownMenu.js
v6.1 files and spaces:
/usr/local/neolane/nl6/deprecated/xtk/css/dropDownMenu.css
/usr/local/neolane/nl6/deprecated/xtk/js/client/dropDownMenu.js

This process is not necessary if migration to Adobe Campaign v6.1 is carried out on a build earlier than 8670.

---

Also, please consider what's mentioned in this page: General configurations​, where you'll find extra information about configuration specificities that might require some attention. For example, about Security Zones that were introduced after 6.02.

Let me know if that helps while waiting for an update from support.

Florent