Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

nlserver command not working in RHEL 7

Avatar

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
Anupam_Maiti
Level 2

15-08-2018

Hi,

I have installed "nlserver6-v7-8857-x86_64_rh7.rpm", I have followed installation steps from Prerequisites & Installing packages 

when I am trying to run any nlserver from "/usr/local/neolane/nl6/bin" getting below error

"./nlserver: error while loading shared libraries: libmozjs.so.1.0: cannot open shared object file: No such file or directory"

No clue how to fix this. Please help.

Thanks in advance.

Warm Regards,

Anupam Maiti

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
Anupam_Maiti
Level 2

31-08-2018

Finally found the solution

Step 1. export LD_LIBRARY_PATH=/usr/local/neolane/nl6/lib/

Step 2. ldconfig

This fixed the issue.

I have tried starting nlserver after creating symbolic links to  "/usr/lib/" though it fixed "cannot open shared object file" issue bit I was getting some other error while starting "nlserver".

Answers (5)

Answers (5)

Avatar

Avatar
Springboard
Level 9
Gaurang
Level 9

Likes

143 likes

Total Posts

435 posts

Correct Reply

45 solutions
Top badges earned
Springboard
Validate 100
Validate 50
Validate 25
Validate 10
View profile

Avatar
Springboard
Level 9
Gaurang
Level 9

Likes

143 likes

Total Posts

435 posts

Correct Reply

45 solutions
Top badges earned
Springboard
Validate 100
Validate 50
Validate 25
Validate 10
View profile
Gaurang
Level 9

31-08-2018

Thanks for sharing the results Anupam! Much appreciated.

Avatar

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
Anupam_Maiti
Level 2

31-08-2018

I have tried this also, Though this fixed "cannot open shared object file" error for some .so files but I was not able to start ./nlserver.

Avatar

Avatar
Level 1
Sau1231
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
Sau1231
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
Sau1231
Level 1

30-08-2018

Try creating symlink in /usr/lib for that library file.

ln -s /usr/local/neolane/nl6/lib/libmozjs.so.1.0 /usr/lib/libmozjs.so.1.0

Then run nlserver command again. If you get further errors, repeat above step for all the files listed in error.

Avatar

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
Anupam_Maiti
Level 2

Likes

4 likes

Total Posts

14 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
Anupam_Maiti
Level 2

20-08-2018

Yes I have done that...still no hope .

Avatar

Avatar
Validate 1
Employee
Vapsy
Employee

Likes

369 likes

Total Posts

726 posts

Correct Reply

342 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
Employee
Vapsy
Employee

Likes

369 likes

Total Posts

726 posts

Correct Reply

342 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Vapsy
Employee

18-08-2018

Hi Anupam,

Did you do

su press Enter

enter root password

Then do

su - neolane

before firing the nlserver commands?