migration from campaign v5.11 to v6.1 postupgrade error

Avatar

Avatar

momokh

Avatar

momokh

momokh

10-05-2018

Hi,

I'm currently upgrading from adobe campaign v5.11 to v6.1, I'm at the step of running the postupgrade, when running the following check command:

nlserver config -postupgrade -instance:neolane -check

I get the following output:

18:54:43 >   Application server for Adobe Campaign (6.1.1 build 8896@507e44c) of 04/13/2018

18:54:43 >   Starting 1 connection(s) on pool 'default neolane' (MSSQL, server='(local)', login='neolane:live')

18:54:43 >>  Missing type definition in schema on attribute '@img' (line 2383, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@runOnSimulation' (line 2384, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 2401, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 2405, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@enabled' (line 2406, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@img' (line 3419, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@runOnSimulation' (line 3420, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@library' (line 3422, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@targetSchema' (line 3427, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 3447, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@enabled' (line 3448, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@img' (line 3563, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@img' (line 3581, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@runOnSimulation' (line 3582, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 3603, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@enabled' (line 3604, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@img' (line 3612, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 3623, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@enabled' (line 3624, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 3627, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@enabled' (line 3628, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 3636, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@reply' (line 3637, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@img' (line 3648, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@runOnSimulation' (line 3649, document 'xtk:workflow'). Using 'string'.

18:54:43 >>  Missing type definition in schema on attribute '@label' (line 3661, document 'xtk:workflow'). Using 'string'.

18:54:43 >   Starting database upgrade for instance 'neolane'

18:54:43 >   Applying 'Check WdbcTimeZone option'...

18:54:43 >   Applying 'Check Schemas/Database coherence'...

18:54:44 >>> Missing argument 'whereFilter' for method 'BuildUpdateSchemaDiff' of schema 'xtk:builder'. (iRc=16384)

18:54:44 >>> Missing argument 'useNamingConventions' for method 'BuildUpdateSchemaDiff' of schema 'xtk:builder'. (iRc=16384)

18:54:44 >>> SCR-160012 JavaScript: error while evaluating script 'inline'. (iRc=-53)

18:54:44 >   Applying 'Check deprecated expressions'...

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'deliveryOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("nms:delivery"...'.

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'deliveryOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("nms:delivery"...'.

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'workflowOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("xtk:workflow"...'.

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'workflowOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("xtk:workflow"...'.

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'dataTransferOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("xtk:jobInterf...'.

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'dataTransferOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("xtk:jobInterf...'.

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'dlvOperationOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("nms:delivery"...'.

18:54:45 >>  [PU-0004] Entity of type : 'xtk:conflict' and Id 'dlvOperationOverview', expression 'new SoapMethodCall' was found : '...var soapCall = new SoapMethodCall("nms:delivery"...'.

I believe I should be focusing on resolving the following errors, in order to move ahead with the migration/upgrade and then be able to fix the rest of the warnings through the client console; once the DB has been upgraded to the new v6.1 standard.

18:54:44 >>> Missing argument 'whereFilter' for method 'BuildUpdateSchemaDiff' of schema 'xtk:builder'. (iRc=16384)

18:54:44 >>> Missing argument 'useNamingConventions' for method 'BuildUpdateSchemaDiff' of schema 'xtk:builder'. (iRc=16384)

18:54:44 >>> SCR-160012 JavaScript: error while evaluating script 'inline'. (iRc=-53)

That said, I don't know how to fix these errors or why they're being generated or where to make the fix. Appreciate your help on this!

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar

momokh

Avatar

momokh

momokh

10-05-2018

I want to also note, that I got the following errors as well in a previous run of postupgrade:

18:54:56 >>> [PU-0006] Entity of type : 'xtk:workflow' and Id 'WKF1818', expression '[SQLDATA[' was found : '...9" expr="@id = [SQLDATA[L390178769.iId]...'. (iRc=-1)

18:54:56 >>> [PU-0006] Entity of type : 'xtk:workflow' and Id 'WKF1405', expression '[SQLDATA[' was found : '...fullName] LIKE [SQLDATA[(SELECT sFullNa...'. (iRc=-1)

However, I was able to fix them by updating to the new xml query condition convention in the XtkWorkflow table... an so on the following postupgrade run these errors did not show up again.