Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Issue with starting web server of Neolane Adobe Campaign

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
View profile
zbeedatm
Level 1

25-07-2017

Hi

I'm following this manual:

  https://docs.campaign.adobe.com/doc/AC6.1/en/INS_Installation_for_Windows__Installing_the_server.htm...

when I reached this command:

> nlserver start web

I'm getting exceptions:

10:02:39 >   Jul 25, 2017 10:02:39 AM org.apache.catalina.core.ContainerBase st

artInternal

SEVERE: A child container failed during start

java.util.concurrent.ExecutionException: org.apache.catalina.Lifec

ycleException: Failed to start component [StandardEngine[Tomcat-St

andalone].StandardHost[localhost].StandardContext[/nl]]

at java.util.concurrent.FutureTask.report(FutureTask.java:122)

at java.util.concurrent.FutureTask.get(FutureTask.java:192)

at org.apache.catalina.core.ContainerBase.startInternal(Containe

rBase.java:1128)

at org.apache.catalina.core.StandardHost.startInternal(StandardH

ost.java:782)

at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.ja

va:150)

at org.apache.catalina.core.ContainerBase$StartChild.call(Contai

nerBase.java:1566)

at org.apache.catalina.core.ContainerBase$StartChild.call(Contai

nerBase.java:1556)

at java.util.concurrent.FutureTask.run(FutureTask.java:266)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolE

xecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPool

Executor.java:617)

at java.lang.Thread.run(Thread.java:748)

Caused by: org.apache.catalina.LifecycleException: Failed to start

component [StandardEngine[Tomcat-Standalone].StandardHost[localhos

t].StandardContext[/nl]]

at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.ja

From the log I can see that issue is related to tomcat:

25, 2017 10:18:39 AM org.apache.catalina.core.ContainerBase startInternal

SEVERE: A child container failed during start

  1. java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Tomcat-Standalone].StandardHost[localhost].StandardContext[/xtk/img]]

From Compatibility Matrix table:
Tools

Java Development Kit (JDK)

  • 6 (32 bits) - from u30
  • 6 (64 bits) - from u39
  • 7 (32 bits) - from u45
  • 7 (64 bits) - from u45

The application has been approved for the Java Development Kit (JDK) developed by Oracle as well as for OpenJDK.

I have java 1.8.0_141 (64bit  last version, both jre & jdk) installed.

But it's still not working for me!

Replies

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
View profile
zbeedatm
Level 1

26-07-2017

I posted the whole conf file (not only tomcat section):

serverConf.xml - Pastebin.com

Avatar

Avatar
Coach
MVP
david_garcia1
MVP

Likes

106 likes

Total Posts

184 posts

Correct Reply

41 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 25
Give Back 10
View profile

Avatar
Coach
MVP
david_garcia1
MVP

Likes

106 likes

Total Posts

184 posts

Correct Reply

41 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 25
Give Back 10
View profile
david_garcia1
MVP

26-07-2017

That seems fine, my java references jave more classes because I am running a higher build.

I am not completely sure what could be the problem, seems like either java or IIS, does your site display virtual folders? these are added after you successfully execute the vbs script. https://db.tt/SSfl4cM3A8

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
View profile
zbeedatm
Level 1

26-07-2017

Nope, no virtual folders were created under my site!
As I mentioned earlier the script didnt run successfuly for me, I got this error:

"Neolane IIS integration cannot be installed. Error Details: [Number:0"

So what can be the issue? the installation itself isn't wrapped properly? we took it from:

<Edit: removed private information>

Somthing wrong I did during the installation?
I ran the setup.exe as administrator and followed the steps, same for running the CMD commands, I had to open it as administrator.

I took the 64bit version (NL-6.1.0.8192-win64.zip), but the one installed is under Program Files (x86) - Hence a 32bit!

Avatar

Avatar
Give Back 50
Level 10
florentlb
Level 10

Likes

237 likes

Total Posts

1,109 posts

Correct Reply

239 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 200
View profile

Avatar
Give Back 50
Level 10
florentlb
Level 10

Likes

237 likes

Total Posts

1,109 posts

Correct Reply

239 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 200
View profile
florentlb
Level 10

04-08-2017

I know there can be some issues with the 64 bit version if other related components (like java) are installed in 32 bit. You may want to try installing a 32 bit version, with a 32 bit java version as well.

Avatar

Avatar
Coach
MVP
david_garcia1
MVP

Likes

106 likes

Total Posts

184 posts

Correct Reply

41 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 25
Give Back 10
View profile

Avatar
Coach
MVP
david_garcia1
MVP

Likes

106 likes

Total Posts

184 posts

Correct Reply

41 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 25
Give Back 10
View profile
david_garcia1
MVP

07-08-2017

Try installing the latest version of Adobe Campaign, if the VBS script did not integrate then you will not have a working environment, first make sure you get this step right, all 64-bit installations seem to install on the x86 folder I am not sure why but it shouldnt be a problem, as florent said, you defo need a 64-bit JDK installed.

Request Adobe Campaign, the latest version and give it another try.