Issue with starting web server of Neolane Adobe Campaign

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile
zbeedatm
Level 1

25-07-2017

Hi

I'm following this manual:

  https://docs.campaign.adobe.com/doc/AC6.1/en/INS_Installation_for_Windows__Installing_the_server.htm...

when I reached this command:

> nlserver start web

I'm getting exceptions:

10:02:39 >   Jul 25, 2017 10:02:39 AM org.apache.catalina.core.ContainerBase st

artInternal

SEVERE: A child container failed during start

java.util.concurrent.ExecutionException: org.apache.catalina.Lifec

ycleException: Failed to start component [StandardEngine[Tomcat-St

andalone].StandardHost[localhost].StandardContext[/nl]]

at java.util.concurrent.FutureTask.report(FutureTask.java:122)

at java.util.concurrent.FutureTask.get(FutureTask.java:192)

at org.apache.catalina.core.ContainerBase.startInternal(Containe

rBase.java:1128)

at org.apache.catalina.core.StandardHost.startInternal(StandardH

ost.java:782)

at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.ja

va:150)

at org.apache.catalina.core.ContainerBase$StartChild.call(Contai

nerBase.java:1566)

at org.apache.catalina.core.ContainerBase$StartChild.call(Contai

nerBase.java:1556)

at java.util.concurrent.FutureTask.run(FutureTask.java:266)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolE

xecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPool

Executor.java:617)

at java.lang.Thread.run(Thread.java:748)

Caused by: org.apache.catalina.LifecycleException: Failed to start

component [StandardEngine[Tomcat-Standalone].StandardHost[localhos

t].StandardContext[/nl]]

at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.ja

From the log I can see that issue is related to tomcat:

25, 2017 10:18:39 AM org.apache.catalina.core.ContainerBase startInternal

SEVERE: A child container failed during start

  1. java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Tomcat-Standalone].StandardHost[localhost].StandardContext[/xtk/img]]

From Compatibility Matrix table:
Tools

Java Development Kit (JDK)

  • 6 (32 bits) - from u30
  • 6 (64 bits) - from u39
  • 7 (32 bits) - from u45
  • 7 (64 bits) - from u45

The application has been approved for the Java Development Kit (JDK) developed by Oracle as well as for OpenJDK.

I have java 1.8.0_141 (64bit  last version, both jre & jdk) installed.

But it's still not working for me!

Replies

Avatar

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile
David__Garcia
Level 6

26-07-2017

Can you please specify the version of Adobe Campaign as well as Operating System

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile
zbeedatm
Level 1

26-07-2017

Hi,

Its Adobe Campaign V6 (C:\Program Files (x86)\Neolane\Neolane v6\tomcat-7) on Windows 10.

Regards,

Muhammad Zbeedat, Campaign Management Team Leader At Adobe

Galil Software

[private info removed by Mod]

Please consider the environment before printing

Avatar

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile
David__Garcia
Level 6

26-07-2017

Can you specifically state the build number please, provide a screenshot of a pdump "nlserver pdump"

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile
zbeedatm
Level 1

26-07-2017

C:\WINDOWS\system32>nlserver pdump

13:29:21 >  Application server for Neolane Version 6.1.0 (build 8192) of 03/31

            /2015

watchdog (5672) - 11.4 MB

syslogd@default (6640) - 13.3 MB

web@default (1540) - 202.3 MB

trackinglogd@default (13812) - 43.4 MB

Regards,

Muhammad Zbeedat, Campaign Management Team Leader At Adobe

[private info removed by Mod]

Please consider the environment before printing

Avatar

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile
David__Garcia
Level 6

26-07-2017

now do a "nlserver monitor -missing".

Can you check that you have correctly setup IIS and executed the iis_neolane_setup.vbs and that "32-bit applications" is set to disabled in the advanced settings of the application pool? can you please confirm how you setup IIS.

Check that redirection module is working by running by navigating to http://localhost/r/test   you should get something like;

<redir status='OK' date='2017-07-26 11:57:03.892+01' build='8770' instance='yourinstancename' sourceIP='::1' host='localhost' localHost='yourHOSTHERE'/>

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile
zbeedatm
Level 1

26-07-2017

  • C:\WINDOWS\system32>nlserver monitor -missing

          14:02:43 >  Application server for Neolane Version 6.1.0 (build 8192) of 03/31

            /2015

          Installed IIS7 (Windows 10) and its up and running, but when running the vbscript \tomcat-7\conf folder\iis_neolane_setup.vbs

          getting:

          "Neolane IIS integration cannot be installed. Error Details: [Number:0

     HTTP Error 404.0 - Not Found

     The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

I suggest that we have a phone call and if you can remotely connect to my computer and check things together.

Please let me know if its possible.

Please consider the environment before printing

Avatar

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile
David__Garcia
Level 6

26-07-2017

Can you please make sure that java tomcat 7 is referenced accordingly in the serverconf file, check the following link https://pastebin.com/4P8gVmer

Also do a "nlserver config -reload" and paste what you got.

Avatar

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
zbeedatm
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
View profile
zbeedatm
Level 1

26-07-2017

I'm missing some jars in my serverConf.xml, like:

$(XTK_INSTALL_DIR)/tomcat-7/lib/tomcat-coyote.jar

$(XTK_INSTALL_DIR)/java/lib/log4j-1.2.11.jar

$(XTK_INSTALL_DIR)/tomcat-7/lib/annotations-api.jar

$(XTK_INSTALL_DIR)/tomcat-7/lib/catalina.jar

$(XTK_INSTALL_DIR)/tomcat-7/lib/websocket-api.jar

$(XTK_INSTALL_DIR)/tomcat-7/lib/tomcat7-websocket.jar

.....

to copy paste all from your link and replace my file content?

  • C:\WINDOWS\system32>nlserver config -reload

15:35:13 >   Application server for Neolane Version 6.1.0 (build 8192) of 03/31

             /2015

15:35:13 >   Asking to reload instances configuration...

Avatar

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile

Avatar
Coach
Level 6
David__Garcia
Level 6

Likes

106 likes

Total Posts

215 posts

Correct reply

44 solutions
Top badges earned
Coach
Builder
Engage 10
Seeker
Bedrock
View profile
David__Garcia
Level 6

26-07-2017

the server config reload should have updated your serverconf, can you post on  pastebin your serverconfig java references please.