Issue in integrating campaing to IIS

gopal_agarwal

01-06-2017

I have followed the steps to install Campaign server Installing the server  & installed the server.

But I am having issue with integrating to IIS Integration into a Web server

I am stuck at this point : Test the tracking module by inserting the following URL into a Web browser:

http://localhost/r/test

The browser should display the following response:

<redir status='OK' date='YYYY/MM/DD HH:MM:SS' build='XXXX' host='myserver.mydomain.com' localHost='localhost'/>

Instead of the response , a file name test is getting downloaded in my computer. File size 8960 kb.

Please help.

Accepted Solutions (0)

Answers (1)

Answers (1)

kishorep

Employee

01-06-2017

Stop nlserver from command line (nlserver shutdown)

Delete the server you configured and re-do the steps in sequence

As instructed in Integration into a Web server , before running step 3 A VBS script enables you to...

Open the file iis_neolane_setup.vbs in any editor and add the below bold line

Line #582

Select Case verOS

  Case "10." GetOSVersion = 8  '= "IIS 8"
  Case "6.3" GetOSVersion = 8  '= "IIS 8"
  Case "6.2" GetOSVersion = 8  '= "IIS 8"
  Case "6.1" GetOSVersion = 7  '= "IIS 7.5"
  Case "6.0" GetOSVersion = 7  '= "IIS 7.0"
  Case "5.2" GetOSVersion = 6  '= "IIS 6.0"
  Case "5.1" GetOSVersion = 5  '= "IIS 5.x"
  'Case "5.0" OSystem = "W2K"
  'Case "4.0" OSystem = "NT 4.0**"
  Case Else GetOSVersion = -1  '= "Unknown IIS version"
  End Select

Good luck!