Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Issue in configuring external account- Share KPI with Adobe Analytics

Avatar

Avatar
Ignite 1
Level 2
anjalis9208738
Level 2

Likes

7 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Ignite 1
Level 2
anjalis9208738
Level 2

Likes

7 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Boost 5
Boost 3
Boost 1
View profile
anjalis9208738
Level 2

09-04-2019

While trying to configure the external accounts for Share KPI with Adobe Analytics, I cannot see any analytics report suites in the drop down. Infact, it is read only.

I took the webservice user name and shared secret key from Admin->Company Settings->Web Services for my username.

Anything I am missing? Please help.

Thanks!

1729499_pastedImage_0.png

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 5
Level 4
aneeta45259594
Level 4

Likes

46 likes

Total Posts

67 posts

Correct Reply

27 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile

Avatar
Give Back 5
Level 4
aneeta45259594
Level 4

Likes

46 likes

Total Posts

67 posts

Correct Reply

27 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile
aneeta45259594
Level 4

12-04-2019

Hi anjalis9208738

The dropdown by default is greyed out and becomes selectable upon successful connection to Analytics. Basically, once you enter the details for Web Service User Name and Shared Secret, hit save and then clicking the "Refresh Report Suites" should populate the dropdown. The web request when you hit the "Refresh Report Suites" button should look like [1] in your browser and it's response brings back a list of Report Suites. See if this request is throwing any errors.

I believe the issue is likely with the Analytics User permissions.

Can you please check the permissions assigned to the Analytics User you're enlisting in this configuration?

Thank you,

Aneet

[1] https://Testinstanceaneet.campaign.adobe.com/rest/head/extAccount/@z8zxijWTEuLWzX0Y4Fi-00ZrQ1tjaYnRR...z8zxijWTEuLWzX0Y4Fi-00ZrQ1tjaYnRRJ15Gm9fUYZHcjkElygCcc9YF-vHwUHoLwDX-TJUPIcrzfImxHG9-DWfdi4/reportSu...:Test&sharedSecret=9092s9a261815e12b2385hdhw894842ffd

Answers (3)

Answers (3)

Avatar

Avatar
Give Back 5
Level 4
aneeta45259594
Level 4

Likes

46 likes

Total Posts

67 posts

Correct Reply

27 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile

Avatar
Give Back 5
Level 4
aneeta45259594
Level 4

Likes

46 likes

Total Posts

67 posts

Correct Reply

27 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile
aneeta45259594
Level 4

09-04-2019

anjalis9208738

The first thing to check is if the Analytics connection details are accurate. The common mistake is while entering the Web Service User Name. It's typically in the form <username>:<TenantID>, Can you confirm this?

Moreover, when you click the button for "Refresh Report Suites", it's supposed to fire a REST call. Can you see what the response to the request is ? It should contain query parameters such as username=&sharedSecret=.

Thank you,

Aneet Arora

Avatar

Avatar
Ignite 1
Level 2
anjalis9208738
Level 2

Likes

7 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Ignite 1
Level 2
anjalis9208738
Level 2

Likes

7 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Boost 5
Boost 3
Boost 1
View profile
anjalis9208738
Level 2

25-04-2019

Thank you, the issue is fixed.

We then reached out adobe helpdesk team and they were able to fix the issue.

Avatar

Avatar
Ignite 1
Level 2
anjalis9208738
Level 2

Likes

7 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Ignite 1
Level 2
anjalis9208738
Level 2

Likes

7 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Boost 5
Boost 3
Boost 1
View profile
anjalis9208738
Level 2

11-04-2019

Thank you for your response.

Yes, the username format is correct. Although when I click refresh report suites, no analytics report suites gets populated and the dropdown "Analytics Default Report Suite" is read only for me. Any thoughts?