Integrating Adobe Experience Manager and Adobe Campaign Standard to create Newsletters

Avatar

Avatar
Give Back 50
Level 10
florentlb
Level 10

Likes

237 likes

Total Posts

1,109 posts

Correct reply

239 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 200
View profile

Avatar
Give Back 50
Level 10
florentlb
Level 10

Likes

237 likes

Total Posts

1,109 posts

Correct reply

239 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 200
View profile
florentlb
Level 10

02-11-2016

A new article about integrating Adobe Experience Manager and Adobe Campaign Standard has been posted on the Adobe Marketing Cloud Help portal. From configuration to the final email, learn how to use these two solutions together:

https://helpx.adobe.com/experience-manager/using/aem_campaign.html

 

Florent.

Replies

Avatar

Avatar
Validate 10
Level 2
Clarence_Bunch_
Level 2

Likes

10 likes

Total Posts

58 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 10
Level 2
Clarence_Bunch_
Level 2

Likes

10 likes

Total Posts

58 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
Clarence_Bunch_
Level 2

01-08-2017

Florent,

I followed those steps and I am getting a

JSON.parse

JSON.parse

SOP-330011 Error while executing the method 'LinkAEMContent' of service 'nms:delivery'.

XTK-170006 Unable to parse expression 'LinkAEMContent(@variant, $(aemPath), $(permalink))'.

RST-360000 Error while assessing 'LinkAEMContent(@variant, $(aemPath), $(permalink))' expression ('nms:delivery:deliveryDetail/content/email/aemLink' resource)

Can you help?

Avatar

Avatar
Establish
Employee
Adhiyan
Employee

Likes

241 likes

Total Posts

343 posts

Correct reply

124 solutions
Top badges earned
Establish
Give Back 50
Give Back 25
Give Back 10
Give Back 5
View profile

Avatar
Establish
Employee
Adhiyan
Employee

Likes

241 likes

Total Posts

343 posts

Correct reply

124 solutions
Top badges earned
Establish
Give Back 50
Give Back 25
Give Back 10
Give Back 5
View profile
Adhiyan
Employee

01-08-2017

Hello Clarence,

Could you please confirm the version of AEM you are using. This looks like a known issue on the AEM side and a patch can fix this issue.

The JSON campaign is trying to parse is present on the AEM server.

Request you to reach out to the AEM support team to get more details about the error.

Regards,

Adhiyan

Avatar

Avatar
Validate 10
Level 2
Clarence_Bunch_
Level 2

Likes

10 likes

Total Posts

58 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 10
Level 2
Clarence_Bunch_
Level 2

Likes

10 likes

Total Posts

58 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
Clarence_Bunch_
Level 2

02-08-2017

Adhiyan,  I was able to resolve this issue.  It was an issue in AEM.  Thanks again.

Avatar

Avatar
Give Back 3
Level 2
shansjtrex
Level 2

Likes

5 likes

Total Posts

13 posts

Correct reply

0 solutions
Top badges earned
Give Back 3
Give Back
Ignite 1
Validate 1
Boost 5
View profile

Avatar
Give Back 3
Level 2
shansjtrex
Level 2

Likes

5 likes

Total Posts

13 posts

Correct reply

0 solutions
Top badges earned
Give Back 3
Give Back
Ignite 1
Validate 1
Boost 5
View profile
shansjtrex
Level 2

20-03-2019

What was the actual fix for this ? I encountered the same problem.

Avatar

Avatar
Give Back 3
Level 2
shansjtrex
Level 2

Likes

5 likes

Total Posts

13 posts

Correct reply

0 solutions
Top badges earned
Give Back 3
Give Back
Ignite 1
Validate 1
Boost 5
View profile

Avatar
Give Back 3
Level 2
shansjtrex
Level 2

Likes

5 likes

Total Posts

13 posts

Correct reply

0 solutions
Top badges earned
Give Back 3
Give Back
Ignite 1
Validate 1
Boost 5
View profile
shansjtrex
Level 2

20-03-2019

Florent/Adhiyan,

What is the actual fix for this ? I encountered the exact same issue. I am using AEM 6.1 SP2

Avatar

Avatar
Validate 1
Level 2
gabrieleg615679
Level 2

Likes

12 likes

Total Posts

36 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 10
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
gabrieleg615679
Level 2

Likes

12 likes

Total Posts

36 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 10
Boost 5
Boost 3
Boost 1
View profile
gabrieleg615679
Level 2

20-11-2019

Did you fix this issue? I've encountered too

Avatar

Avatar
Validate 1
Level 2
gabrieleg615679
Level 2

Likes

12 likes

Total Posts

36 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 10
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
gabrieleg615679
Level 2

Likes

12 likes

Total Posts

36 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Boost 10
Boost 5
Boost 3
Boost 1
View profile
gabrieleg615679
Level 2

28-11-2019

My problem was that on the server url for the AEM setting on campaign there was the port 4502. I used ngrok to set up a temporary url to test it.