How to insert element into schema using xtk.session.Write

Avatar

Avatar

boguslawb113716

Avatar

boguslawb113716

boguslawb113716

27-03-2017

Hi Team,

I've got issue with inserting data into my custom table. I'm able to insert attribute of my table, but cannot update the element.

I'm using the following expression:

xtk.session.Write(<qaSurvey _operation="insert" Question3="BoguslawTest33" email="test@test.com" Edited_Question="BoguslawTest35" xtkschema="adbe:qaSurvey"/>);

and my database have the following schema: 

 <element autopk="true" label="QA Survey" name="qaSurvey">
    <key internal="true" name="internal">
      <keyfield xpath="@id"/>
    </key>
    <attribute label="Primary key" name="id" notNull="false" sqlname="iId" type="long"/>
    <element label="Edited_Question" name="Edited_Question" sqlname="sEdited_Question"
             type="string"/>
    <attribute label="Email (Responses to recipient forms/Recipient)" name="email"
               sqlname="sEmail" type="string"/>
    <element label="XML memo" name="data" sqlname="mData" type="memo"/>
    <element label="Question" name="Question3" type="memo"/>
  </element>

As a result of my query I'm getting a new row with Primary key and email address only. Question3 and Edited_Question are blank.

How can I insert the Question3 and Edited_Question elements to my table?

Best Regards,
Boguslaw

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

ddphotoFr

Employee

Avatar

ddphotoFr

Employee

ddphotoFr
Employee

28-03-2017

Hi,

 

your write expression should be:

xtk.session.Write(<qaSurvey _operation="insert" email="test@test.com" xtkschema="adbe:qaSurvey"> <Question3>BoguslawTest33</Question3> <Edited_Question>BoguslawTest35</Edited_Question> </qaSurvey>);

Damien

Answers (0)