Getting error in campaign- You are not authorised to use SQL Expressions.'IsIMSLoggedIn' cannot be processed

Senthil24

06-01-2017

Hi,

I am learning how to use Adobe Campaign tool and while I was working on that I had a requirement of importing few packages using Adobe Campaign package feature for Creating External Instance.

After the package import I am facing this issue of a particular type of error- You are not authorised to use SQL Expressions.'IsIMSLoggedIn' cannot be processed. (see attachment). I dont know the reason for it but this has cropped up after the package import.

Anyone has any idea why this errror is showing up and how to resolve it. It will be very helpful.

Thanks.smiley

Accepted Solutions (1)

Accepted Solutions (1)

Adhiyan

Employee

09-01-2017

Hi Senthil,

 

I checked the screenshot , your Console is 8601 and server is 8720. So even if version is same the builds are different.

Please upgrade your client to 8720 as well and the error will not appear.

The reason is that some components of the server was upgraded and when you use the old client it's not able to properly view the changed components. 

Answers (15)

Answers (15)

Adhiyan

Employee

10-01-2017

Hi Senthil,

You can use the same link to install the client of build 8720 . Once you put in https://<campaign instance>/nl/jsp/logon.jsp in the browser you should be re-directed to download the same client version as the server . Once you install it just launch the nlclient.exe and login and check the server and client version

florentlb

10-01-2017

I think the issue is indeed happening because of the version mismatch between console and server (8601 vs. 8720 is really big difference - lots of builds in between that have required console update).

Just in case, you should be able to add named rights to operators from the operator details under Administration > Access management > Operators. Click Edit, then go to the Access rights tab. From there, you should be able to add the named right. See screenshot attached.

 

Florent

Senthil24

10-01-2017

Adhiyan wrote...

Hi Senthil,

Let me know if this solves the issue

 

Hi adhiyan, 

I have informed about this build version upgrade to my supervisors here. Since this is a training environment, upgradation might take some time, I am not sure when that will happen .

When it gets done, I will let you know for sure. Thanks for helping. 🙂 

Note: This error pops up many times, but except for that it hasn't actually disrupted any of the workflows or deliveries.  

Senthil24

10-01-2017

Adhiyan wrote...

Hi Senthil,

You can use the same link to install the client of build 8720 . Once you put in https://<campaign instance>/nl/jsp/logon.jsp in the browser you should be re-directed to download the same client version as the server . Once you install it just launch the nlclient.exe and login and check the server and client version

 

Thanks adhiyan.

Senthil24

10-01-2017

florentlb wrote...

I think the issue is indeed happening because of the version mismatch between console and server (8601 vs. 8720 is really big difference - lots of builds in between that have required console update).

Just in case, you should be able to add named rights to operators from the operator details under Administration > Access management > Operators. Click Edit, then go to the Access rights tab. From there, you should be able to add the named right. See screenshot attached.

 

Florent

 

Thank you so much florent.

Senthil24

09-01-2017

florentlb wrote...

Hi Senthil,

The URL you mentioned should offer you the possibility to install the right console. If not, contact the person in charge of upgrading the server to request that the right version of the console is made available, as explained here: https://docs.campaign.adobe.com/doc/AC6.1/en/INS_Installation_for_Windows__Client_console_availabili...

Hope this helps,

Florent

 

Thanks florent,

I will see about upgrading the client console ,however I wanted to ask you about the named rights issue that you mentioned earlier. Did you check that one? Do you think there might be an issue with that as well?

Or the problem occurs because of build mismatch?

florentlb

09-01-2017

Hi Senthil,

The URL you mentioned should offer you the possibility to install the right console. If not, contact the person in charge of upgrading the server to request that the right version of the console is made available, as explained here: https://docs.campaign.adobe.com/doc/AC6.1/en/INS_Installation_for_Windows__Client_console_availabili...

Hope this helps,

Florent

Senthil24

09-01-2017

Adhiyan wrote...

Hi Senthil,

 

I checked the screenshot , your Console is 8601 and server is 8720. So even if version is same the builds are different.

Please upgrade your client to 8720 as well and the error will not appear.

The reason is that some components of the server was upgraded and when you use the old client it's not able to properly view the changed components. 

 

Thanks adhiyan,

Any inputs on how to upgrade the build version of the campaign client will be helpful as I have installed it using the training environment provided to me in the format http://<yourAdobeCampaignserver>:<port number>/nl/jsp/logon.jsp

Senthil24

08-01-2017

florentlb wrote...

Hi,

Can you make sure your user has the necessary named rights? There should be one dedicated to executing SQL expressions.

For reference, here is the list of available named rights: https://docs.campaign.adobe.com/doc/AC6.1/en/PTF_Administration_Elements_Access_management.html#Name...

 

Florent.

 

Hi Florent, thanks for your reply.

I have checked for the named right that you mentioned via
Administration->Access Management->Named rights( ss attached ). But I am not quite sure how to check if a particluar operator has these names rights. When I checked under Administration->Access Management->Operators-> clicked on a particular user , I could only find Access rights.(ss attached) 

Any help on how to verify that a particualr operator has the required named rights.

Note:- ss here means screenshot.

Thanks.

Senthil

Senthil24

08-01-2017

Adhiyan wrote...

Hi Senthil,

 

Can you please check the build of the server and the client from help>about in campaign console

This usually happens when there is a version mismatch between the version of server and client . Try to use the same version and the error should not appear.

 

Hi Adhiyan, 

Thanks for replying . Just checked the build of the server and client. They are of  same verison.

6.1.1. Attaching the screenshot for reference.

Adhiyan

Employee

06-01-2017

Hi Senthil,

 

Can you please check the build of the server and the client from help>about in campaign console

This usually happens when there is a version mismatch between the version of server and client . Try to use the same version and the error should not appear.