Error while evaluating document

Avatar

Avatar

sqwgglz

Avatar

sqwgglz

sqwgglz

02-02-2018

Hi,

I'm attempting to enrich data from a table that has a 1-N relationship with my recipient table into my delivery so I can make the content conditional on a number.

This is my workflow:

1409167_pastedImage_1.png

I have a list of my mailable customers which has an additional query to select only those who met the criteria.

1409187_pastedImage_6.png

In my enrichment, I only want 1 column, where the "brand code" is equal to "BE"

1409178_pastedImage_3.png

The columns I'm enriching with are the one's below...

1409179_pastedImage_4.png

Here's the advanced join condition so I only pull data where the brand code is equal to BE.

1409177_pastedImage_2.png

I think my logic is correct however when I try pull in a field I've enriched I get this error in the Preview.

1409192_pastedImage_13.png

1409166_pastedImage_0.png

Can anyone see where I'm going wrong?

Any help would be greatly appreciated.

Thanks

Kevin

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

sqwgglz

Avatar

sqwgglz

sqwgglz

26-04-2018

Hey all,

Sorry for the late reply.

So I found out that the preview system wasn't working, but on sending a full test to myself, the above actually worked and calculated the points correctly.

We can mark this as closed.

Thanks

Kevin

Answers (10)

Answers (10)

Avatar

Avatar

florentlb

Total Posts

1.1K

Likes

234

Correct Answer

239

Avatar

florentlb

Total Posts

1.1K

Likes

234

Correct Answer

239
florentlb

04-04-2018

Hi Kevin,

Any progress on your side?

Florent

Avatar

Avatar

florentlb

Total Posts

1.1K

Likes

234

Correct Answer

239

Avatar

florentlb

Total Posts

1.1K

Likes

234

Correct Answer

239
florentlb

13-03-2018

Hi Kevin,

Can you give us more details about what is not working after following Shrawan's suggestions?

Florent

Avatar

Avatar

sqwgglz

Avatar

sqwgglz

sqwgglz

28-02-2018

shrawans31530030 unfortunately not.

Avatar

Avatar

shrawans3153003

Employee

Avatar

shrawans3153003

Employee

shrawans3153003
Employee

27-02-2018

Yes Kevin. Please follow the same steps for other subset,save the workflow and run it again to see if it works

Avatar

Avatar

sqwgglz

Avatar

sqwgglz

sqwgglz

27-02-2018

Actually just did it....

When you asked to select "Schema" did you mean like so?


Thanks

Kevin

1428794_pastedImage_0.png

Avatar

Avatar

sqwgglz

Avatar

sqwgglz

sqwgglz

27-02-2018

Apologies, I've been away from the business so have not had chance to implement the suggestions.

Will attempt today and reply ASAP


Thanks again

Avatar

Avatar

florentlb

Total Posts

1.1K

Likes

234

Correct Answer

239

Avatar

florentlb

Total Posts

1.1K

Likes

234

Correct Answer

239
florentlb

20-02-2018

Hi,

Any update on this?

Florent

Avatar

Avatar

shrawans3153003

Employee

Avatar

shrawans3153003

Employee

shrawans3153003
Employee

06-02-2018

Hello,

Could you please try the following and see if it helps

Open Split Object

·         Click on “First subset"

·         Click on “Previous” to go to “Targeting and Filtering dimension”

·         Click on Schema dropdown menu

·         Select “schema”

·         Click Next

·         Click on Finish

·         Apply same on other subset

·         Save workflow

Avatar

Avatar

sqwgglz

Avatar

sqwgglz

sqwgglz

05-02-2018

Hi thanks for looking.

The version we're on is v6.1.1 Console build 8653. Server build 8667

Avatar

Avatar

shrawans3153003

Employee

Avatar

shrawans3153003

Employee

shrawans3153003
Employee

03-02-2018

Hi Kevin,

Workflow logic implemented seems fine.

Could you please let me know you are on which build (Server and console build)