Creating Profile via API - not displayed in Campaign

nicolais5628580

12-09-2018

Hi,

we are currently trying to set up the REST API. The POST operation to create a new profile in the database seems to work correctly, and the new Profile can also be found via API.

However, the new profile is not displayed in our Campaign Instance (neither in the "Profiles" tab nor via a Query). What could be the reason for this?

Best regards,

Nicolai

Accepted Solutions (1)

Accepted Solutions (1)

Vapsy

Employee

13-09-2018

Hi nicolais56285807,

I sensed you will be using profileAndServices endpoint.

So, the problem most probably is that you have extended the Profile Resource which creates the profileAndServicesExt endpoint.

Your API call is going to the generic endpoint which will help you create a profile with the fields bundled into factory provided Profile columns.

The Profile screen works on the profileAndServicesExt endpoint and hence your created profiles are not visible there. Please refer to this link Adobe Campaign Standard API

1570618_pastedImage_1.png

Please use this URL

https://mc.adobe.io/<tenant>/campaign/profileAndServicesExt/profile/.

Answers (2)

Answers (2)

nicolais5628580

12-09-2018

Hi Vipul,

thank you for the quick reply.

API call is fired as POST to https://mc.adobe.io/<tenant>/campaign/profileAndServices/profile/.

Answer returns a "201 Created" and the JSON of the new profile.

Kind regards,

Nicolai

Vapsy

Employee

12-09-2018

Hi Nicolai,

Can you please share the API endpoint you are firing the call to? You can hide the customer specific subdomain but do share the entire URL

Regards,
Vipul