Accepted Solutions (0)

Answers (6)

Answers (6)

Vapsy

Employee

03-06-2017

Hi Sumit,

The question is not completely clear.

Either of the two things might have happened here.

  1. You've deleted the recipient schema
  2. You've deleted the underlying table.

If the table has been deleted, you can recover it from the last day's backup if you are maintaining it. In case the instance is Adobe hosted, we do take daily backups which are available for 7 days before being purged.

In case you have deleted the schema, please export the schema from another environment say the Dev instance and import it into the current affected environment. This step has to be followed if you had done customizations to factory recipient schema.

If you are using OOB version, please feel free to hit the Regenerate schema button.

Hope this helps.

Regards,
Vipul

yassinen4240628

27-09-2019

Hello,

If you need to force regeneration of all schema, for example to solve certain dependency problems in the reverse links, you can launch the following command from the Adobe Campaign application server:

nlserver config -postupgrade -instance:`<instance_name>' -force
You must then restart the Adobe Campaign application server and disconnect/reconnect to the client console.

sadafali

12-07-2018

Hi Vipul,

Actually when I try to hit the Regenerate schema option I get the below error -

1526419_pastedImage_0.png

Can you help me with this. Thanks in Advance

Regards,

Sadaf

sadafali

11-07-2018

Hi Vipul,

Could you please tell the steps of how to export schema from one instance to another? Or if there is any link describing the same could you please share.

Thanks,

Sadaf

sumitc28215684

04-06-2017

Hi Vipul,

My recipient schema was showing error that @id (primary key) is missing. So I deleted it and tried to import it from the postgres sql table.

But it didn't work. I am new to this tool and so working on local, so no prod/dev environments are there.

For now, I have reinstalled the Adobe campaign and exported the recipient schema to avoid this hassle later.

Also, I have another question here.. In schema I can see some MD5 key being generated, but when I export the schema, it is not in the exported file. So, I am not sure if I import the exported schema then it will work. Could you please guide me on this.

Regards,

Sumit