Highlighted

AC Standard - Workflow still sent message after opt-out.

Avatar

Avatar

phuongl3280170

Avatar

phuongl3280170

phuongl3280170

30-06-2018

Hi, we are running a workflow to send out 2 emails that targets the subscribers of this campaign only (we are using the incremental query to connect the schedule). The second email will be sent out 2 days after the first one. At the bottom of all emails, we have 2 links: one is opt-out from this certain email campaign (unsubscribed from this email campaign only)  and the other is opt-out from all kinds of communication (blacklist, no longer contact by any channel).

When the user clicks the blacklist link, they no longer receive any email of this campaign from us --->>> This is just right as we expected.

However, when the user clicks the unsubscription link to opt-out from this email campaign only, they still receive the second email after 2 days like normal.--->> This is not what we expect.

also checked the profile of this user (my test profile) and saw that he was totally unsubscribed from this campaign. The subscripts tab was empty and in the event list, it showed all the event, including (1) subscribing to the campaign, then (2) received the confirmation email (to confirm to be in email list, double opt-in), then (3) got the 1st email sent by workflow, then (4) unsubscribing from this specific campaign by clicking the link at the bottom at the email, then (5) he still received the 2nd email even he chose to opt-out already. (Please see my attachment). 

We are using all defaultTypology rule set for all the emails in the workflow which already has the control rule like Check unsubscription link (urlOptout) so I am really confused and don't know how to solve this problem.

Any who know how to deal with this case?

Thank you so much.

2.PNG

defaultTypology.PNG

Replies

Highlighted

Avatar

Avatar

pablo_rosero1

Avatar

pablo_rosero1

pablo_rosero1

30-11-2018

Hi Phuong,

Opt-out profiles for a specific delivery are listed after the preparation phase, in the Exclusion logs tab of the delivery dashboard. Perhaps, you should check the Exclusion Logs to make sure opt-outs are getting excluded correctly.

Hope this helps!

All the best,

Pablo